summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-11 08:49:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-11 10:01:37 +0200
commitc629e018fd4c0cdf7730bc43e36cfb9c0d323e95 (patch)
treeab20fbc2f2fdda98494a0eedb9d5f0890c5e2a94 /dev-python
parentwww-client/opera: Old (diff)
downloadgentoo-c629e018fd4c0cdf7730bc43e36cfb9c0d323e95.tar.gz
gentoo-c629e018fd4c0cdf7730bc43e36cfb9c0d323e95.tar.bz2
gentoo-c629e018fd4c0cdf7730bc43e36cfb9c0d323e95.zip
dev-python/botocore: Bump to 1.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 2831262d2b7f..731887946f66 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,3 +7,4 @@ DIST botocore-1.16.20.tar.gz 6442160 BLAKE2B 23ad33e53ebf810087958f003d21fe58749
DIST botocore-1.16.26.tar.gz 6458468 BLAKE2B e753f7dcb3d75a86da78536883e44cbd493fd3ff48fae86e5e1959e55d2d66fe8dcb33ee46af51b39390ce7d2227bdb193a827932b53dc5a4b56f985faeebd31 SHA512 66ba4e9bd8ae72a31fa093dc7d8eccd646a12381086f524e3bd63d6031f2d75bad5e241f08e5588a6ac6c16eac693d0410b1858641bf8e59decfb1e6ed16b360
DIST botocore-1.16.6.tar.gz 6386032 BLAKE2B e909e2fa021d5b1be333a31758af408cdc6e11224addefac31b87b8ce9983350aeaaf862feaf040490fad8eb87d7dde800bd8a77156410e6a734f567e2cc1055 SHA512 1f265a0a8adb7f0172f02448d3be5aeacf11e3fb7023da8d81e6d19c39d97cac99cfe3a70997e682deb44a4fd78304e4a0c1df43787f3139bbccbe852c682a82
DIST botocore-1.16.7.tar.gz 6391893 BLAKE2B 19a8770ef1058e5601a1c292e2e17e1625e4d5d0d1845b59bbd403a2c285da1a774935e9d1e1fa7ca26a1e3c4703b29fcbb2f021a7251aa3ca756c80b2ba0461 SHA512 0ab2b4ff4096049cd92b96c710a38867a53b2dba0f07a319ec1a2f9b3cbce60776026c62e3eaaebe571b6ad26eb5c1c258b2dd350a444d30e54b342bcd675768
+DIST botocore-1.17.0.tar.gz 6478558 BLAKE2B 761ff2d57079a52ce38a6d56639fb0771d1fc4fb6a3494badecaacd4cea1ef74a69fe23d9fe62827993a3b6c33b963a2a199300f37fa3e7dc42433135c00f035 SHA512 a43b2f99e44ef9de3cf740b8fc1d74976d9ff6831639229a704f9300011405861789c9af26ea657f64244f5d67cff19aa94f95e5d2df73ee4f2dc10ccdeabae3
diff --git a/dev-python/botocore/botocore-1.17.0.ebuild b/dev-python/botocore/botocore-1.17.0.ebuild
new file mode 100644
index 000000000000..c08c6f6ff899
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}