summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 10:56:24 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 14:39:19 +0100
commitc934d668fe554f19fbe5cefb528c0d3bec09fd4c (patch)
treee17cb0ebc16663e4bf796367d2118892a07326c5 /dev-python
parentdev-python/wsaccel: Clean old up (diff)
downloadgentoo-c934d668fe554f19fbe5cefb528c0d3bec09fd4c.tar.gz
gentoo-c934d668fe554f19fbe5cefb528c0d3bec09fd4c.tar.bz2
gentoo-c934d668fe554f19fbe5cefb528c0d3bec09fd4c.zip
dev-python/wsgiproxy2: Clean old up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wsgiproxy2/Manifest1
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/wsgiproxy2/Manifest b/dev-python/wsgiproxy2/Manifest
index 205586940558..3aa79290d2e5 100644
--- a/dev-python/wsgiproxy2/Manifest
+++ b/dev-python/wsgiproxy2/Manifest
@@ -1,3 +1,2 @@
-DIST WSGIProxy2-0.4.1.zip 18437 BLAKE2B dda2ad39eec9ad455b61ba2871a125f46f000c94ce2dff2c3e49fec5af4bedf1fa3eceb722d0db9a5144f854c59952c83665b9f76827406b0ab88fc6b8cdce82 SHA512 794cf74d47366ab80f03ef311cd77258b4152f266cabf662b3eccb0f706f246d6d4407f495432ed32520ed69ecf3cb5ae05ef8a50e7f59062c6ef7395d8c9eec
DIST WSGIProxy2-0.4.2.zip 18817 BLAKE2B 90334926b726024c1a16b066d11cfe579ad80515861811766753aa772fa97e521466bce0a08c028a965e51ec40b977feb1f4b59aa6c023ca6a431deb63668ed5 SHA512 3dd750263485ceb644373d8ea9692c9a46126a1ed7cd640feba7d42b0fe618e290dcae2f76dc83be77de34211ac473f5a1496a8309e3fcc64982e9642af786fb
DIST WSGIProxy2-0.4.4.tar.gz 16475 BLAKE2B 8cc91e8364204a03fb8f80abb926e69112c2224b595c695d25e2fa54553fe9c82e3420f68b58f266d04450dd49a6dbf9257c190da8645dfeee976ae101fc708b SHA512 6ae9fca65fe80f52924f42b26b447631e8c278f517ababc23d26e5f8598d6d9b7975197ec74faf64f2e051824366ac14c5db5727a014a187c70a1b4604105b42
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild
deleted file mode 100644
index 932c46971df8..000000000000
--- a/dev-python/wsgiproxy2/wsgiproxy2-0.4.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-MY_PN="WSGIProxy2"
-
-DESCRIPTION="HTTP proxying tools for WSGI apps"
-HOMEPAGE="http://pythonpaste.org/wsgiproxy/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc64 ~s390 ~sh sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- dev-python/socketpool[${PYTHON_USEDEP}]
- dev-python/restkit[$(python_gen_usedep python2_7)] )"
-# Tests needing restkit are skipped under py3
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build -b html -d _build/doctrees . _build/html
- fi
-}
-
-# this was always possible
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}