summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 13:37:14 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 13:37:40 +0100
commitd1248c2078c184eeb06d2bfe22f80a06d7840452 (patch)
treeab823826c94e867ea19e2e5d79449ad32a882b66 /dev-python
parentdev-python/cytoolz: Bump (diff)
downloadgentoo-d1248c2078c184eeb06d2bfe22f80a06d7840452.tar.gz
gentoo-d1248c2078c184eeb06d2bfe22f80a06d7840452.tar.bz2
gentoo-d1248c2078c184eeb06d2bfe22f80a06d7840452.zip
dev-python/datashape: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/datashape/Manifest1
-rw-r--r--dev-python/datashape/datashape-0.4.7.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/datashape/Manifest b/dev-python/datashape/Manifest
index 6ccd353f2198..7da5f61c35fa 100644
--- a/dev-python/datashape/Manifest
+++ b/dev-python/datashape/Manifest
@@ -2,3 +2,4 @@ DIST datashape-0.4.2.tar.gz 79106 SHA256 56ca27c5eb090d3670d3f59d2cd4a9855c48849
DIST datashape-0.4.4.tar.gz 80923 SHA256 c4142eadbdb986a350941e5427d35a2aa106934f9197e91ccb53809c4c79e394 SHA512 047127e070b1cbecd241a888a8b2d773ee149d05e08556644ae0add79f774be9795caab8b8c6de146dc9281ebfd93aadbcb54c2c08fc8fa7f1612834cecf9753 WHIRLPOOL 8294278a940f2a89e525e1133d5870c320b37d1cf1f48f24b267fa792c1599695e8b72cdda6a455500cd8d6d008d394791ba5ea71c7ff42d71da9059bcf47268
DIST datashape-0.4.5.tar.gz 93549 SHA256 34d4922fa924ef474de2ef8b69833fe2d5da51703d74426f8c4354c9bb209d0f SHA512 f8fcaf923640e42d0ceb6cd607e89b74145443f33ec1d4c0018dc0093518d572ae890bf582487b0c2de6c9d793e96ebb7dc901a330150f2ef2f203b329db5968 WHIRLPOOL cb78a9fd8337d9047c473914f216a06ff3797cc3fc494982696ba8c379d3e50e7cc194f84557eada06fe8459d3711589ad6e1404eb2ae9e389e81e104d447ce0
DIST datashape-0.4.6.tar.gz 94083 SHA256 872929d992929ee23ea939984d43d726458ddaa3367503bb4678edac81a4b854 SHA512 596b997ebf9f3b05d5c7d686514408630a987b5933ded24e5cfe1321ea32b1cb4b2f99b820c3e2ec608fdf5fcb1ec795f256bbc14c0ec2e6e8f21b61b083d696 WHIRLPOOL e85917492996b81d01f6c3c5577f5a446ce141c3518d332709a95d40584a77898b59264f3d03bd87a33d39df63854225020e604ca06341e090eeacd541a14047
+DIST datashape-0.4.7.tar.gz 92581 SHA256 1028378bb56e8546a07cd3ad09247672516468ab395aa87646c4791488ba1794 SHA512 c5e4f9ef36456d6673c7cb50297d36cf0080cb08d9da81ff044853cc9bb52d659bc6c0beeb6d95d47ff6924aab50b67ac28eb906e7049624fe5d923a304c0ad0 WHIRLPOOL 7bfc2491a8598cc5a3574ced486d6b19308f45155002a0703e4d57fdc23f2ad270cde500ed65af9520a69c6538bf3622f733a19d56509bd65e5bb981d64118ec
diff --git a/dev-python/datashape/datashape-0.4.7.ebuild b/dev-python/datashape/datashape-0.4.7.ebuild
new file mode 100644
index 000000000000..9a7769308fcd
--- /dev/null
+++ b/dev-python/datashape/datashape-0.4.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}