summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-08-13 23:44:56 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-08-13 23:44:56 -0500
commitdc211c73034f4266ae6c76a9ee37e4d02f59ddb5 (patch)
tree6203b9aa93915d4f76c4a533f7317c285e23c8ed /dev-python
parentapp-portage/eclass-manpages: fail when there are errors in eclass docs (diff)
downloadgentoo-dc211c73034f4266ae6c76a9ee37e4d02f59ddb5.tar.gz
gentoo-dc211c73034f4266ae6c76a9ee37e4d02f59ddb5.tar.bz2
gentoo-dc211c73034f4266ae6c76a9ee37e4d02f59ddb5.zip
dev-python/pbr: bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-1.5.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 0446612fc9c6..7d2780234312 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -6,3 +6,4 @@ DIST pbr-1.1.1.tar.gz 97607 SHA256 3d63cc8e145e5e20624859d6453d783ae1451704483ae
DIST pbr-1.2.0.tar.gz 99092 SHA256 1543fc3e00261369c160fc8cf700717aad15fbc1f0ea0e8dc4f372cb91a655d0 SHA512 e5adc396596f4b42a8eb569c970a3cf571b119740b9ca221dc57c6f34c088df1dbfca3c704b7dd3b2d6676d48f9eba17ddb535e28ef6ab0572206620b894c5a2 WHIRLPOOL 6baaeecc6dc7c228d76f7a8f42af19cf179540483267ea863323e09654a3faac0cabbea6dc6d83b36e0c4496cd5872f05e1e9b7f5c5a36272fc746f84e2dd504
DIST pbr-1.3.0.tar.gz 99701 SHA256 1a6f8d514fc11d2571c75c207d932c106f024f199b5f12d25f8ca022b026c59d SHA512 29f661a1d8bed6df5017bb342209e702f19e72c321952a9131d84222162599208bea67922485a87b6f3505e072d62cb13fdfcdd4fbb7c085b3476f6ff5a07df9 WHIRLPOOL 978d943efd2f582b8067a898f102005c749df8addee4ec3d6f4f4c4078e3190263ceba46409281e7bd38ab59ad12f45d3d208cfd6ba58ece72d973161dfd08e9
DIST pbr-1.4.0.tar.gz 102181 SHA256 f080232fb6b208615b4c1854bf4277bb097d19c9ef89f94f203c1436fe600e92 SHA512 c6ccc8fd6598e089eb80342ce0d76f26dd1242eedb64aa7c0020be43ba74b1591cff52a5eec9d9c9b958315e7902b78bf120bf758aacc28fcec3f07ac5173150 WHIRLPOOL 9cee1204273256588982065c388c06e053253ebd2ae242a89b5f60a8052c1fe58e2136a30c289b8278131e9487a902ce8902e883cbd3b73c34f9fe87de1229c5
+DIST pbr-1.5.0.tar.gz 99436 SHA256 bd6db6ecddf5d8ab40d7d554508c29cfe0d150a1789f07d4dd32abe896068e7e SHA512 249f5db847199eca7d39ca7a80509a8b5b86c9163474463e00d1612905b84fab11208c79408154983269d9a096d3337e3ab44968e281989b0ebf7e81fd7ffde1 WHIRLPOOL d53637256da8e1e67aa2d1f921c006d94fa5c96b9844ab39a9991d6a764e344f305ad68aa8476497b817af7c53f7acaa354eecd1d85321daff636f5ac4c903a5
diff --git a/dev-python/pbr/pbr-1.5.0.ebuild b/dev-python/pbr/pbr-1.5.0.ebuild
new file mode 100644
index 000000000000..8e15c8a78863
--- /dev/null
+++ b/dev-python/pbr/pbr-1.5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/pip[${PYTHON_USEDEP}]"
+
+# Requ'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ einfo "rogue tests disabled"
+
+ distutils-r1_python_prepare_all
+}
+
+PATCHES=( )
+
+python_test() {
+ # Note; Tests, that have been removed, pass once package is emerged.
+ esetup.py testr
+}