summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-10-03 13:44:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-10-03 13:46:44 -0500
commitde91af2e1ac8f13872225c9827bac713618de2a4 (patch)
treea43cfc4a5387235667a16c4b3907c8bd8f58f496 /dev-python
parentdev-php/smarty: Version bump (diff)
downloadgentoo-de91af2e1ac8f13872225c9827bac713618de2a4.tar.gz
gentoo-de91af2e1ac8f13872225c9827bac713618de2a4.tar.bz2
gentoo-de91af2e1ac8f13872225c9827bac713618de2a4.zip
dev-python/python-zaqarclient: adding for heat
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-zaqarclient/Manifest1
-rw-r--r--dev-python/python-zaqarclient/metadata.xml19
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild40
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/Manifest b/dev-python/python-zaqarclient/Manifest
new file mode 100644
index 000000000000..80fb1d8c1869
--- /dev/null
+++ b/dev-python/python-zaqarclient/Manifest
@@ -0,0 +1 @@
+DIST python-zaqarclient-1.2.0.tar.gz 66649 SHA256 afe1a0a32b9595feb8dd15c8f5affd23e80c4c4ecd73fef3a7d17076cb9cf39b SHA512 1590839460815daa1f0754d47ef789e0c2d2a078265bbb6595eac32114a36c5f15512a2781841955fe99cbdf2cdaa8a13061f535229a284f5b98f97d017dd8a2 WHIRLPOOL 5b47eabb2aba03e1a9168946e9b0018b3ca6e3099a5a34e2147a58786c5bef3c47fc97a8360a042d58c13e30e4cd4fda0d13d2f95d1481364e46719fa11ed40d
diff --git a/dev-python/python-zaqarclient/metadata.xml b/dev-python/python-zaqarclient/metadata.xml
new file mode 100644
index 000000000000..f538ac4d0baf
--- /dev/null
+++ b/dev-python/python-zaqarclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a client for the OpenStack Zaqar API.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-zaqarclient</remote-id>
+ <remote-id type="github">openstack/python-zaqarclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
new file mode 100644
index 000000000000..8df77396d218
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.0.2[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}