summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 01:07:03 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 01:07:57 -0500
commite4f3d79bbaed56094b1898920b2d7a8a9b8175f1 (patch)
treea2f304d3a87c270b1ee21964f0bc5d1e8f6ba76e /dev-python
parentnet-analyzer/sslscan: add 2.0.4 (diff)
downloadgentoo-e4f3d79bbaed56094b1898920b2d7a8a9b8175f1.tar.gz
gentoo-e4f3d79bbaed56094b1898920b2d7a8a9b8175f1.tar.bz2
gentoo-e4f3d79bbaed56094b1898920b2d7a8a9b8175f1.zip
dev-python/python-heatclient: 2.2.1 bump
Closes: https://bugs.gentoo.org/747226 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-heatclient/Manifest1
-rw-r--r--dev-python/python-heatclient/python-heatclient-2.2.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-heatclient/Manifest b/dev-python/python-heatclient/Manifest
index 1ff3fb5b82ee..5137b261b741 100644
--- a/dev-python/python-heatclient/Manifest
+++ b/dev-python/python-heatclient/Manifest
@@ -1 +1,2 @@
DIST python-heatclient-1.17.0.tar.gz 172475 BLAKE2B 79dbaa2b6f3bc5e97ac4f2630e3e5ef5a320b7b37b1abdfee5ce66df6c63c9d488770135ffdaff53d3e88f93becd8f26019c4c1967624693c9c0ce1479055181 SHA512 44a16f32ede251c36546a0dcab2ca2ca0e145ce924f257c623cc375e52a851094639529a77d770d2703e28f9446e27e03424240fdc0272096e91703180dd6190
+DIST python-heatclient-2.2.1.tar.gz 172925 BLAKE2B 3ecccdb8647f1d78c13680158db60cfbf0f8a7415636337caca171785bf5ae06516055df619b013b7d73218ccb1cb0a697e5312ea0aef40e4445b281bb740c21 SHA512 9798dbf2def1aa160d5773dc5da57cd1b1a372bd9e734e8bbf89e817e84dfa03cb36519d0b805624dba1259964b8311c729a1632531e1c659765acc483c9f024
diff --git a/dev-python/python-heatclient/python-heatclient-2.2.1.ebuild b/dev-python/python-heatclient/python-heatclient-2.2.1.ebuild
new file mode 100644
index 000000000000..52850e8b648c
--- /dev/null
+++ b/dev-python/python-heatclient/python-heatclient-2.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Orchestration API Client Library"
+HOMEPAGE="https://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"