summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 10:31:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 13:18:42 +0200
commite8107e87eac45bec2807f74df7896da56e078ae9 (patch)
tree9f7c426f5b2f25f5558a5cd454ea1b53dde7336a /dev-python
parentdev-python/calver: New package, v2021.7.30 (diff)
downloadgentoo-e8107e87eac45bec2807f74df7896da56e078ae9.tar.gz
gentoo-e8107e87eac45bec2807f74df7896da56e078ae9.tar.bz2
gentoo-e8107e87eac45bec2807f74df7896da56e078ae9.zip
dev-python/trove-classifiers: New package, v2022.6.23
This was originally needed for validate-pyproject but that package is too bad to be included in Gentoo. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/metadata.xml11
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2022.6.23.ebuild34
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
new file mode 100644
index 000000000000..ff70d51e74ac
--- /dev/null
+++ b/dev-python/trove-classifiers/Manifest
@@ -0,0 +1 @@
+DIST trove-classifiers-2022.6.23.gh.tar.gz 14950 BLAKE2B 7203b8edb6f8a8886371a60f3c273b02b7fe045230a3a0c89a7282a896e513535a47fe06834fd6e33b98c480695b69be524dea1402f463f3c82fc80ddf8ac320 SHA512 c2c186b5d13f626a43f29a1eff6ebf2f17f8240af554f27ffdf05b506d428dd59582e7357a85b62f94714e024ae98ea216487726526639371c24c6b46b96df4e
diff --git a/dev-python/trove-classifiers/metadata.xml b/dev-python/trove-classifiers/metadata.xml
new file mode 100644
index 000000000000..210953a4e27e
--- /dev/null
+++ b/dev-python/trove-classifiers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pypa/trove-classifiers</remote-id>
+ <remote-id type="pypi">trove-classifiers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/trove-classifiers/trove-classifiers-2022.6.23.ebuild b/dev-python/trove-classifiers/trove-classifiers-2022.6.23.ebuild
new file mode 100644
index 000000000000..964617661415
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2022.6.23.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+SRC_URI="
+ https://github.com/pypa/trove-classifiers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}