summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-07-25 04:48:45 -0400
committerTim Harder <radhermit@gentoo.org>2017-07-25 04:48:45 -0400
commite9201c35afbb6dd586c1a975caf6774cc8d6821b (patch)
treeb7f85249840c18709fcc318342ef25c7b24736d9 /dev-python
parentdev-python/pycairo: version bump to 1.15.0 (diff)
downloadgentoo-e9201c35afbb6dd586c1a975caf6774cc8d6821b.tar.gz
gentoo-e9201c35afbb6dd586c1a975caf6774cc8d6821b.tar.bz2
gentoo-e9201c35afbb6dd586c1a975caf6774cc8d6821b.zip
dev-python/apsw: version bump to 3.19.3_p1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.19.3_p1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index fb1e2abaec14..52623414e720 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,2 +1,3 @@
DIST apsw-3.11.1_p1.zip 679045 SHA256 92685d555bb5bdbf5ec85563cd826f76630c33a589ef2528e8f14f73a8bcc95f SHA512 3976b14ade967b2e39fdd18436e7a9a2f8f4f5b289ee93725878bd8bfa15ccb7548156df8cca981f494a4cdcc7aaed5370fde2b805e6eea022892ece1231bd96 WHIRLPOOL 8ad615ba3b5f15cdd36c15a370b036a4fddf92b69b6b0058d3fdf8d83bd2b39251d11b3cd291319c08ad09baf3f26d1b0cff3d54777e6c7169e335e985a0d1e9
DIST apsw-3.17.0_p1.zip 689144 SHA256 ceed784f28afec5045571892da4740a0e03d6d6d581ed24a818c67f0a189dd1c SHA512 9fc63f3596aaa931b526efed5ffc0654d80477ae2cd27361430d8376641eedf7bba482edcf65e99f0cac4ed42597805c6c95f28ff9843502c779335df5d38b77 WHIRLPOOL c9dafef922dbdaa0655fd1773498d2e4d9e209ea5ca90a3478852f33629369bd99b0670a4f116da491b4db07bb4b8137863b2831922bf15b88bba4e3b8463b6e
+DIST apsw-3.19.3_p1.zip 678966 SHA256 355b66379e9e44c1f32bc67421e4ad0a348a19bf279a4256a49d0eb83fff404e SHA512 9f9e05c865a19e7b6e6b37e6228027c027ba683be2d5ff7a1767bb3bbeb090bf66879a0eead4fc9e34fc4d84c1edc98137b2839f84ffab9bd36330d05435ab4e WHIRLPOOL 6703b13f42711f95a86a1c4a0e20bfc378823c24ee78c1ad7bb4e956bd9a927abe777a0c8c9b81c7d24130b76ba2019e048465e0cc59575a8e419f1b97847d7a
diff --git a/dev-python/apsw/apsw-3.19.3_p1.ebuild b/dev-python/apsw/apsw-3.19.3_p1.ebuild
new file mode 100644
index 000000000000..f2bb6b9990b9
--- /dev/null
+++ b/dev-python/apsw/apsw-3.19.3_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="https://github.com/rogerbinns/apsw/"
+SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-db/sqlite-${PV%_p*}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
+
+python_compile() {
+ python_is_python3 || append-cflags -fno-strict-aliasing
+ distutils-r1_python_compile --enable=load_extension
+}
+
+python_test() {
+ "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
+ "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}