summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-11-08 21:19:29 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-11-09 21:30:53 +0100
commitea36c6f29f920778aa7843a55d3520ebee11e032 (patch)
treec2d7f832cbf6936c3d25b0c69efd73b0f2cdad86 /dev-python
parentapp-misc/jq-1.7_pre20201109: Version bump to snapshot version (diff)
downloadgentoo-ea36c6f29f920778aa7843a55d3520ebee11e032.tar.gz
gentoo-ea36c6f29f920778aa7843a55d3520ebee11e032.tar.bz2
gentoo-ea36c6f29f920778aa7843a55d3520ebee11e032.zip
dev-python/nuitka: version bump to 0.6.9.6.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/18194 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/metadata.xml2
-rw-r--r--dev-python/nuitka/nuitka-0.6.9.6.ebuild43
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 03a70ab72541..1d8fe788b653 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.6.9.1.tar.gz 2470517 BLAKE2B b3162eed308d98846a6266fa822d851757773ef9910a250644d61627d70dcc29706f5127221e2c09b1f856b74262c64f10cc638ec336a53d1fd6a10ad53e4e29 SHA512 a94a2e7f86abdbbdaa0147e569ff873c4d0f439378afb0f55ce78ea6e22a16ac759b62fd617944e0a4cf98fbe3294db5e56c3b3a6bd8cb78bd1c1132d557f6a9
+DIST Nuitka-0.6.9.6.tar.gz 2472086 BLAKE2B acee6dc787f24afb6c1843e82bd4fdcda3a45c4c8a74cb5635d5fb2aec6b1a8db64920993b1732e21f3d0866e47f81cd958f42fe577c592931053248976ab33a SHA512 9a4d2b0e947e26118c9e81fc93c63ccc344a0a4d577e2ccd2d6b1ccafacef3eb3d7424283e681b63dde44fa51aad84d86f76e2c839d22d7d1503730e0ab72ab8
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
index a082b06e69cd..50c557ea4749 100644
--- a/dev-python/nuitka/metadata.xml
+++ b/dev-python/nuitka/metadata.xml
@@ -16,6 +16,6 @@
be used in the same way as pure Python objects.
</longdescription>
<upstream>
- <remote-id type="github">pwman3/pwman3</remote-id>
+ <remote-id type="github">Nuitka/Nuitka</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/nuitka/nuitka-0.6.9.6.ebuild b/dev-python/nuitka/nuitka-0.6.9.6.ebuild
new file mode 100644
index 000000000000..0b8a77447b0c
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+
+RDEPEND="${BDEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+S="${WORKDIR}/${P^}"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}