summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-21 16:28:51 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-21 16:30:08 +0200
commitebf9e4919796106103cd1a8ff4ee19e78d405b63 (patch)
treef83762cb730c516afc468056ca409acfe1717196 /dev-python
parentsys-apps/coreutils: mark stable (bug #660786) (diff)
downloadgentoo-ebf9e4919796106103cd1a8ff4ee19e78d405b63.tar.gz
gentoo-ebf9e4919796106103cd1a8ff4ee19e78d405b63.tar.bz2
gentoo-ebf9e4919796106103cd1a8ff4ee19e78d405b63.zip
dev-python/minidb: EAPI=7, add python 3.7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/minidb/minidb-2.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/minidb/minidb-2.0.2-r1.ebuild b/dev-python/minidb/minidb-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..51dff2891b1d
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}