summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-25 19:46:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-25 20:01:26 +0300
commitf50a3a39c8ea76bf61ca9321d148218fde8f1412 (patch)
treec287bdd5ad7547a9986d660566a2cd86668c7a56 /dev-python
parentsys-kernel/vanilla-sources: Automated removal of old 5.17.15 since it is EOL (diff)
downloadgentoo-f50a3a39c8ea76bf61ca9321d148218fde8f1412.tar.gz
gentoo-f50a3a39c8ea76bf61ca9321d148218fde8f1412.tar.bz2
gentoo-f50a3a39c8ea76bf61ca9321d148218fde8f1412.zip
dev-python/pdm-pep517: add 1.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pdm-pep517/Manifest1
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-1.0.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pdm-pep517/Manifest b/dev-python/pdm-pep517/Manifest
index 1afd248261f0..d21727cd3ee0 100644
--- a/dev-python/pdm-pep517/Manifest
+++ b/dev-python/pdm-pep517/Manifest
@@ -1 +1,2 @@
DIST pdm-pep517-0.12.7.gh.tar.gz 304959 BLAKE2B 0571a77803b999f88f38da843c5fcf126eeb538c6812c3e245be2fc14d6cd19929559985efba2d245bbf0efb00e412b2133fca6bbe9e63317e6b7311867e0072 SHA512 45da8ab31071a57062fac5b89abe7d912d787d647eda1b45fe3941c43687fe0fe5c8d11e539290035375e17eef808489000513e3128708fcefd851e792757b8f
+DIST pdm-pep517-1.0.0.gh.tar.gz 307117 BLAKE2B 6af1cbeb10bfcf040aaaaf60535d660c00ad84f0a186b508112e224df7eed417ce97ec1bdbf2764549172ecbededf4e9b17b6ae915b71599f04d09f2103c0a7c SHA512 cb8c02af8c4f00cf68e6379c2e93aa0ab7d30f4405debb62f7c46afc10596ab440128f1a7444fe6989d5eafb462bbbe0cfc83325bc1aba92268498a3d96332e8
diff --git a/dev-python/pdm-pep517/pdm-pep517-1.0.0.ebuild b/dev-python/pdm-pep517/pdm-pep517-1.0.0.ebuild
new file mode 100644
index 000000000000..65915f36678c
--- /dev/null
+++ b/dev-python/pdm-pep517/pdm-pep517-1.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-pep517/
+ https://github.com/pdm-project/pdm-pep517/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-pep517/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r pdm/pep517/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.pep517\._vendor\.:from :' \
+ -e 's:from pdm\.pep517\._vendor ::' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}