summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-03 12:02:32 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-04 22:28:45 +0100
commitf718efb3295eacf789be57b328125ecf0060d050 (patch)
tree378156a9239323b030b9c4f58c11696aa0d664ff /dev-python
parentdev-python/notebook: Version bump to 4.3.2 (diff)
downloadgentoo-f718efb3295eacf789be57b328125ecf0060d050.tar.gz
gentoo-f718efb3295eacf789be57b328125ecf0060d050.tar.bz2
gentoo-f718efb3295eacf789be57b328125ecf0060d050.zip
dev-python/nbdime: Version bump to 0.1.2
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3786
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/nbdime-0.1.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index 40dcd99234c4..8c70c51b7333 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1 +1,2 @@
DIST nbdime-0.1.0.tar.gz 3849944 SHA256 5af53ccf5b265546e61fbc096c4dd8122855b2aa02f8b60a99eeee01a8e33043 SHA512 e110e2e3e8b9bfbaafd26e6558ec863eb0a23f3b7a67482e497c4883fa2151ae058582b975aca90392bd2314f5e32ce3e7316db9c2c37e44c336a9fcf88176c8 WHIRLPOOL 074060d867b259b461514e84b21c0f7eb20ff2f787055e03971fd18d0aa1ba56596b15017354c5becd3f1022b5557ec740d4815d4f820af8b54349273ee8b9a4
+DIST nbdime-0.1.2.tar.gz 3864624 SHA256 4adb8ff052a7c778fb5f00872172a3790504de392eb7f23b6ae96b8a8165a695 SHA512 9f704645ef1e64b0da260841769068db6f6aba37f30b3c6506a1876af1276acb452ed78f66b9e6d7029f06ed9fabf01a1484b4b86055f27a451d623a7eda90cf WHIRLPOOL 570891b1f9067abe88009f7160f509f8cba6345742df3d0549a486b8669f84c097487d25855f76ddea3ee8d786131145467ea20bedf3d54bca30a137977b7978
diff --git a/dev-python/nbdime/nbdime-0.1.2.ebuild b/dev-python/nbdime/nbdime-0.1.2.ebuild
new file mode 100644
index 000000000000..718527d03392
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}