summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-01-17 11:37:25 +0100
committerMarek Szuba <marecki@gentoo.org>2018-01-17 11:44:16 +0100
commitfa36b42010b9e5fd29c7d3482bb8ca2898f1d893 (patch)
tree94fa39015ed9244eea4be68cfbe2881d920a1096 /dev-python
parentmedia-video/smplayer: Bump to version 18.1.0 (diff)
downloadgentoo-fa36b42010b9e5fd29c7d3482bb8ca2898f1d893.tar.gz
gentoo-fa36b42010b9e5fd29c7d3482bb8ca2898f1d893.tar.bz2
gentoo-fa36b42010b9e5fd29c7d3482bb8ca2898f1d893.zip
dev-python/pyicu-2.0.2: skip tests on python2
test_Script/testSurrogatePairs fails on UCS-4 builds of python2_7, which is what Gentoo (and most Linux distributions) use. Upstream has been aware of the issue since November 2017 but has not fixed it yet. Gentoo-Bug: https://bugs.gentoo.org/644226 Upstream-Bug: https://github.com/ovalhub/pyicu/issues/61 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyicu/pyicu-2.0.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/pyicu/pyicu-2.0.2.ebuild b/dev-python/pyicu/pyicu-2.0.2.ebuild
index 1e6ff018f986..4dc247fee2d4 100644
--- a/dev-python/pyicu/pyicu-2.0.2.ebuild
+++ b/dev-python/pyicu/pyicu-2.0.2.ebuild
@@ -31,5 +31,10 @@ S="${WORKDIR}/${MY_P}"
DOCS=(CHANGES CREDITS README.md)
python_test() {
- esetup.py test
+ if [[ ${EPYTHON} == python2* ]]; then
+ # See Bug #644226
+ ewarn "Skipping tests for ${EPYTHON} because they are known to fail"
+ else
+ esetup.py test
+ fi
}