summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-01-29 11:05:23 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-29 11:11:21 +0100
commitfc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7 (patch)
treed9000079c2ba5d4025c6d6959691ce2e6fd22119 /dev-python
parentnet-misc/icaclient: Removed old. (diff)
downloadgentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.tar.gz
gentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.tar.bz2
gentoo-fc8a2a8c318e38e2112dcc2df03cb75d28a4f1a7.zip
dev-python/pythondialog: version bump to 3.4.0.
This commit: * alters python-3.4.0.ebuild's slot to 0 for Python 3.x and pypy3 interpreters. * adds python-3.4.0-r200.ebuild using slot "python-2" for Python 2.7 and pypy interpreters. An EAPI 6 bump is crammed in whilst we're at it. Closes: https://bugs.gentoo.org/639188 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pythondialog/Manifest1
-rw-r--r--dev-python/pythondialog/pythondialog-3.4.0-r200.ebuild38
-rw-r--r--dev-python/pythondialog/pythondialog-3.4.0.ebuild22
3 files changed, 46 insertions, 15 deletions
diff --git a/dev-python/pythondialog/Manifest b/dev-python/pythondialog/Manifest
index fe9a4adda5d8..e3a5d959746c 100644
--- a/dev-python/pythondialog/Manifest
+++ b/dev-python/pythondialog/Manifest
@@ -2,3 +2,4 @@ DIST python2-pythondialog-3.3.0.tar.gz 1906527 BLAKE2B 67fbb2dbd2b9c5f5da4c74f53
DIST python2-pythondialog-3.4.0.tar.gz 1487867 BLAKE2B 795af99391e7a3d5e9b0657116dba8fd85819261a9ac590e797d0144577d66261529515cf8421a4724b6eacd0b6c7ae20d030bc7eb22c56ef870294c6f2386d3 SHA512 f4ec3e3eeab9ee00146b4604a8f72c765fcc164a24def0f1a9cbf083123e55dbe371ce6d4790ad4c0b5ee6905a1877f9b8e90ca3443a780fa0965c9bcf4bf629
DIST python3-pythondialog-3.2.2.tar.bz2 1412368 BLAKE2B 2c20347a09720c15c696795826e9d24034a0f85b16936ff145511d50830e116436b30868bcd53fbe425929709f7bede0a422257ba8231a9f2846d3f15b3a7709 SHA512 58b84c0dd7b71ec9d1e60c4802cfc8e6cc72f79b8b6accd387553c685a92367d242746065bac6cb1c9d501ac291d9307cb2bb6b26694e9f24a3c5d6637a5bb8e
DIST python3-pythondialog-3.3.0.tar.bz2 1827891 BLAKE2B ef78832972cc2417ecedc797cb95ea10b1fcca4ff1ab2f7db74a9afaefddeedfee8303f2f4b9ff7230f3d2eea305e359f3854112abaefa2a4adf4c801de7ffe0 SHA512 b651593f077f6679be030182ac5f14a02d8bad86206c2733ba8b655d346809a32ea391de91e35101d400c55d9e8ecefaf6f1ba25fec036246186e13530f43a1f
+DIST python3-pythondialog-3.4.0.tar.bz2 1415324 BLAKE2B 1135df25b988dfaacd45a68dd918409e001719f92436e9e88fcf1a66e9ba70f03fdef1b86ebb80ca6a1c02006353ed3f9df998a5bfaacb9505d6e8a96a37d5d9 SHA512 a810128459133c4e416f4b04b8dd98b2230f046b8762e6b29c4e02e1458fa96029d37137a71cc01aee292106867a6f30026941ed1f727b7e48cbe976d96d7ed4
diff --git a/dev-python/pythondialog/pythondialog-3.4.0-r200.ebuild b/dev-python/pythondialog/pythondialog-3.4.0-r200.ebuild
new file mode 100644
index 000000000000..78974d96017e
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.4.0-r200.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
+HOMEPAGE="http://pythondialog.sourceforge.net/ https://pypi.python.org/pypi/python2-pythondialog"
+SRC_URI="mirror://pypi/${PN:0:1}/python2-${PN}/python2-${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="python-2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-util/dialog"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/python2-${P}"
+
+python_prepare_all() {
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pythondialog/pythondialog-3.4.0.ebuild b/dev-python/pythondialog/pythondialog-3.4.0.ebuild
index 35c80c28d2df..8a5f44a07b90 100644
--- a/dev-python/pythondialog/pythondialog-3.4.0.ebuild
+++ b/dev-python/pythondialog/pythondialog-3.4.0.ebuild
@@ -1,32 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python3_{4,5,6} pypy3 )
inherit distutils-r1
DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
-HOMEPAGE="http://pythondialog.sourceforge.net/ https://pypi.python.org/pypi/python2-pythondialog"
-SRC_URI="mirror://pypi/${PN:0:1}/python2-${PN}/python2-${P}.tar.gz"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
LICENSE="LGPL-2"
-SLOT="python-2"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="doc examples"
RDEPEND="dev-util/dialog"
DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/python2-${P}"
-
-python_prepare() {
- if python_is_python3; then
- 2to3 -w --no-diffs setup.py || die "could not convert to Python 3"
- fi
-}
-
python_prepare_all() {
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
distutils-r1_python_prepare_all
@@ -37,7 +29,7 @@ python_compile_all() {
}
python_install_all() {
- use examples && local EXAMPLES=( examples/. )
+ use examples && dodoc -r examples
use doc && local HTML_DOCS=( doc/_build/html/. )
distutils-r1_python_install_all