summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-28 20:07:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-01 10:24:37 +0100
commit1b4c9f2dbdb4fb32ab0250f0f5904a6985881059 (patch)
treebf72c58aa1c524fd65380ffa26b406148449b0ec /dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild
parentqt5-build.eclass: Relocate QT5_DOCDIR to /usr/share/qt5-doc (diff)
downloadgentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.tar.gz
gentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.tar.bz2
gentoo-1b4c9f2dbdb4fb32ab0250f0f5904a6985881059.zip
dev-qt: Add Qt 5.12.1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild
new file mode 100644
index 000000000000..c610b7cd0001
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.12.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}