summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-11 01:20:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 14:03:14 +0100
commit608616191dce3dca8e059a86bd960c2ab0e44c39 (patch)
tree877828aaee7d7a7223ac76abdabe8c52a09fabf6 /dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild
parentdev-qt/qtbluetooth: Fix build with GCC-11 (diff)
downloadgentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.tar.gz
gentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.tar.bz2
gentoo-608616191dce3dca8e059a86bd960c2ab0e44c39.zip
dev-qt: Fix build for QT5_MODULE=qtbase w/ GCC-11
Closes: https://bugs.gentoo.org/752012 Closes: https://bugs.gentoo.org/764038 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild
index bdaa4c333573..d5caa7070696 100644
--- a/dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.15.2.ebuild
@@ -2,10 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
@@ -21,3 +23,5 @@ RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/concurrent
)
+
+PATCHES=( "${WORKDIR}"/qtbase-${PV}-gcc11.patch ) # bug 752012