summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-02-11 02:20:51 +0100
committerDavide Pesavento <pesa@gentoo.org>2016-02-11 02:21:21 +0100
commit9bb2a44f5b0d10108ff4749943882a83e2467826 (patch)
treee468a97e185a279c5fd25c3bbd11bad675e7641e /dev-qt/qtcore/qtcore-5.5.1-r1.ebuild
parentqt5-build.eclass: extend the fix for bug 552942 to all arches (diff)
downloadgentoo-9bb2a44f5b0d10108ff4749943882a83e2467826.tar.gz
gentoo-9bb2a44f5b0d10108ff4749943882a83e2467826.tar.bz2
gentoo-9bb2a44f5b0d10108ff4749943882a83e2467826.zip
dev-qt/qtcore: revbump to ensure users get the fix for bug 552942
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-qt/qtcore/qtcore-5.5.1-r1.ebuild')
-rw-r--r--dev-qt/qtcore/qtcore-5.5.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtcore/qtcore-5.5.1-r1.ebuild b/dev-qt/qtcore/qtcore-5.5.1-r1.ebuild
new file mode 100644
index 000000000000..9f424843a643
--- /dev/null
+++ b/dev-qt/qtcore/qtcore-5.5.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Cross-platform application development framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="icu systemd"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libpcre-8.35[pcre16]
+ >=sys-libs/zlib-1.2.5
+ virtual/libiconv
+ icu? ( dev-libs/icu:= )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qatomic_ia64.h.patch" # bug 559802
+)
+
+QT5_TARGET_SUBDIRS=(
+ src/tools/bootstrap
+ src/tools/moc
+ src/tools/rcc
+ src/corelib
+ src/tools/qlalr
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use icu)
+ $(qt_use systemd journald)
+ )
+ qt5-build_src_configure
+}