summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qthelp/qthelp-4.8.6-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qthelp/qthelp-4.8.6-r3.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-4.8.6-r3.ebuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-4.8.6-r3.ebuild b/dev-qt/qthelp/qthelp-4.8.6-r3.ebuild
new file mode 100644
index 000000000000..c74d57733ebe
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-4.8.6-r3.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-build-multilib
+
+DESCRIPTION="The Help module for the Qt toolkit"
+SRC_URI+="
+ compat? (
+ http://download.qt.io/archive/qt/4.6/qt-assistant-qassistantclient-library-compat-src-4.6.3.tar.gz
+ http://dev.gentoo.org/~pesa/distfiles/qt-assistant-compat-headers-4.7.tar.gz
+ )"
+
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS="alpha arm ia64 ppc ppc64"
+else
+ KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+IUSE="compat doc"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ ~dev-qt/qtsql-${PV}[aqua=,debug=,sqlite,${MULTILIB_USEDEP}]
+ compat? (
+ ~dev-qt/qtdbus-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+ tools/assistant/lib/fulltextsearch
+ tools/assistant/lib
+ tools/assistant/tools/qhelpgenerator
+ tools/assistant/tools/qcollectiongenerator
+ tools/assistant/tools/qhelpconverter
+ tools/qdoc3"
+
+pkg_setup() {
+ use compat && QT4_TARGET_DIRECTORIES+="
+ tools/assistant/compat
+ tools/assistant/compat/lib"
+}
+
+src_unpack() {
+ qt4-build-multilib_src_unpack
+
+ # compat version
+ # http://blog.qt.io/blog/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/
+ if use compat; then
+ mv "${WORKDIR}"/qt-assistant-qassistantclient-library-compat-version-4.6.3 "${S}"/tools/assistant/compat || die
+ mv "${WORKDIR}"/QtAssistant "${S}"/include || die
+ find "${S}"/tools/assistant/compat -type f -execdir chmod a-x '{}' + || die
+ fi
+}
+
+src_prepare() {
+ use compat && PATCHES+=(
+ "${FILESDIR}/${PN}-4.8.6-compat-install.patch"
+ "${FILESDIR}/${PN}-4.8.6-compat-syncqt.patch"
+ )
+
+ qt4-build-multilib_src_prepare
+
+ # prevent rebuild of QtCore and QtXml (bug 348034)
+ sed -i -e '/^sub-qdoc3\.depends/d' doc/doc.pri || die
+}
+
+multilib_src_configure() {
+ local myconf=(
+ -system-libpng -system-libjpeg -system-zlib
+ -no-sql-mysql -no-sql-psql -no-sql-ibase -no-sql-sqlite2 -no-sql-odbc
+ -sm -xshape -xsync -xcursor -xfixes -xrandr -xrender -mitshm -xinput -xkb
+ -no-multimedia -no-opengl -no-phonon -no-qt3support -no-svg -no-webkit -no-xmlpatterns
+ -no-nas-sound -no-cups -no-nis -fontconfig
+ )
+ qt4_multilib_src_configure
+}
+
+multilib_src_compile() {
+ qt4_multilib_src_compile
+
+ # release tarballs are shipped with prebuilt docs
+ if [[ ${QT4_BUILD_TYPE} == live ]] && multilib_is_native_abi; then
+ # qhelpgenerator needs libQtHelp.so.4
+ export LD_LIBRARY_PATH=${BUILD_DIR}/lib
+ export DYLD_LIBRARY_PATH=${BUILD_DIR}/lib:${BUILD_DIR}/lib/QtHelp.framework
+ emake docs
+ fi
+}
+
+multilib_src_install() {
+ qt4_multilib_src_install
+
+ if multilib_is_native_abi; then
+ emake INSTALL_ROOT="${D}" install_qchdocs
+ use doc && emake INSTALL_ROOT="${D}" install_htmldocs
+
+ # do not compress .qch files
+ docompress -x "${QT4_DOCDIR#${EPREFIX}}"/qch
+ fi
+}
+
+multilib_src_install_all() {
+ qt4_multilib_src_install_all
+
+ if use compat; then
+ insinto "${QT4_DATADIR#${EPREFIX}}"/mkspecs/features
+ doins tools/assistant/compat/features/assistant.prf
+ fi
+}