summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qtpaths
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qtpaths')
-rw-r--r--dev-qt/qtpaths/Manifest1
-rw-r--r--dev-qt/qtpaths/metadata.xml9
-rw-r--r--dev-qt/qtpaths/qtpaths-5.4.2.ebuild24
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtpaths/Manifest b/dev-qt/qtpaths/Manifest
new file mode 100644
index 000000000000..021b32a107b9
--- /dev/null
+++ b/dev-qt/qtpaths/Manifest
@@ -0,0 +1 @@
+DIST qttools-opensource-src-5.4.2.tar.xz 9333100 SHA256 edf3d7e00227f9989101da84b2fdf8eaf1a5b7863dc5e0d26bb0f39303e8b6b4 SHA512 55aa04eae16b71e78d4432e7d59b2052392d13652a3e9beff15a6503f2e88e77a9b48279121d8eee943a898799155c05b167d986bf01fae84b5db0a9a1759148 WHIRLPOOL 9123ff33a35c03adaa6d3374e86b539e9481ec78467bd72ad6f2d832e76e7aafd9b2f2da0420111e1aa8a66c4950b0478d8a6ae4c0f0e05a20c8334196b077e8
diff --git a/dev-qt/qtpaths/metadata.xml b/dev-qt/qtpaths/metadata.xml
new file mode 100644
index 000000000000..afb3b434585b
--- /dev/null
+++ b/dev-qt/qtpaths/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtpaths/qtpaths-5.4.2.ebuild b/dev-qt/qtpaths/qtpaths-5.4.2.ebuild
new file mode 100644
index 000000000000..017dd584962e
--- /dev/null
+++ b/dev-qt/qtpaths/qtpaths-5.4.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Tool to query Qt path information"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtcore-${PV}:5
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtpaths
+)