summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qtpositioning
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qtpositioning')
-rw-r--r--dev-qt/qtpositioning/Manifest1
-rw-r--r--dev-qt/qtpositioning/metadata.xml13
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.4.2.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-qt/qtpositioning/Manifest b/dev-qt/qtpositioning/Manifest
new file mode 100644
index 000000000000..98304b11636a
--- /dev/null
+++ b/dev-qt/qtpositioning/Manifest
@@ -0,0 +1 @@
+DIST qtlocation-opensource-src-5.4.2.tar.xz 3325280 SHA256 dc4af26e5398222aade1f7e405b6c8c0caaca7de0df910b8da20c5ff058583ec SHA512 89b9983a8dca4948602f62a6fa1447479a84c140b56d452599c77c641107bf495a3ef52b3a80fcf37839e918f90cac0381d4f5dfbb57d97b7a5a08033d57cf85 WHIRLPOOL ec7607f236ac66de959ba01b2132683d94a5fd74d11f6a511691e745c1358654da6cda1f201ebb7e7d0a46a9d4858c386bf254319539817e69e1991f5bfca95f
diff --git a/dev-qt/qtpositioning/metadata.xml b/dev-qt/qtpositioning/metadata.xml
new file mode 100644
index 000000000000..0d64dfddc921
--- /dev/null
+++ b/dev-qt/qtpositioning/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="geoclue">Use enhanced location information from <pkg>app-misc/geoclue</pkg></flag>
+ <flag name="qml">Build QML bindings</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtpositioning/qtpositioning-5.4.2.ebuild b/dev-qt/qtpositioning/qtpositioning-5.4.2.ebuild
new file mode 100644
index 000000000000..aeb0529b91da
--- /dev/null
+++ b/dev-qt/qtpositioning/qtpositioning-5.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+QT5_MODULE="qtlocation"
+inherit qt5-build
+
+DESCRIPTION="Physical position determination library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+# TODO: src/plugins/position/gypsy
+IUSE="geoclue qml"
+
+RDEPEND="
+ >=dev-qt/qtcore-${PV}:5
+ geoclue? (
+ app-misc/geoclue:0
+ dev-libs/glib:2
+ )
+ qml? ( >=dev-qt/qtdeclarative-${PV}:5 )
+"
+DEPEND="${RDEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/positioning
+ src/plugins/position/positionpoll
+)
+
+pkg_setup() {
+ use geoclue && QT5_TARGET_SUBDIRS+=(src/plugins/position/geoclue)
+ use qml && QT5_TARGET_SUBDIRS+=(src/imports/positioning)
+}