summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-13 16:26:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-18 18:15:28 +0200
commit1c0947091db651f4e7d136e22d4887b47d9245cd (patch)
treedd264a79b23c6103b138807ca5b05d76fcd07959 /dev-qt/qtquickcontrols2
parentmedia-sound/alsa-utils: x86 stable (bug #749159) (diff)
downloadgentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.tar.gz
gentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.tar.bz2
gentoo-1c0947091db651f4e7d136e22d4887b47d9245cd.zip
dev-qt: Drop Qt 5.14.2
Bug: https://bugs.gentoo.org/734600 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtquickcontrols2')
-rw-r--r--dev-qt/qtquickcontrols2/Manifest1
-rw-r--r--dev-qt/qtquickcontrols2/files/qtquickcontrols2-5.14.2-account-for-scale-before-positioning.patch61
-rw-r--r--dev-qt/qtquickcontrols2/qtquickcontrols2-5.14.2-r1.ebuild34
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-qt/qtquickcontrols2/Manifest b/dev-qt/qtquickcontrols2/Manifest
index 0a33aab87fd1..6e7231e26813 100644
--- a/dev-qt/qtquickcontrols2/Manifest
+++ b/dev-qt/qtquickcontrols2/Manifest
@@ -1,2 +1 @@
-DIST qtquickcontrols2-everywhere-src-5.14.2.tar.xz 8153752 BLAKE2B d1803007fb016276b75db9102ebfd82a6afa279b845d3507a04b76c2ab6fc8345840f3ea76c12607ed2b7be11e2b2c26bb76ff84b65a4c8df7cf9c66dbd95003 SHA512 de8b669417c2d039c0f49e805be72e757877991bc3c7feb13417202a4964cb6391924837751c520ed6234930e90dfe00417ca1c369418b2cdf4f09da679ba722
DIST qtquickcontrols2-everywhere-src-5.15.1.tar.xz 8282444 BLAKE2B 94be5403a3642ceb1ce8eb7ceae2a116743f5ee75c0614448bbfb846918d108f3c5bb6ad881bb63eb30082f0bbeed28a49e32456d335e67f19dc65418c76216a SHA512 ecb75619e80b737e3ae214f65a5175d933f8dc7832eb4eccd469fc1cb1eb85ef5c47f81563165da2d75abf15d7c47b868e68ab758d95183371b4ef64e7c52a39
diff --git a/dev-qt/qtquickcontrols2/files/qtquickcontrols2-5.14.2-account-for-scale-before-positioning.patch b/dev-qt/qtquickcontrols2/files/qtquickcontrols2-5.14.2-account-for-scale-before-positioning.patch
deleted file mode 100644
index ae54f12f3652..000000000000
--- a/dev-qt/qtquickcontrols2/files/qtquickcontrols2-5.14.2-account-for-scale-before-positioning.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 4df52eee2b40244ba1a3d115a43ed51cfd742105 Mon Sep 17 00:00:00 2001
-From: Andy Shaw <andy.shaw@qt.io>
-Date: Thu, 7 Feb 2019 17:35:51 +0100
-Subject: [PATCH] Menu: account for the scale when getting the size before
- positioning
-
-Fixes: QTBUG-73687
-Change-Id: Id2d6a6b5c6651337ab7ae26d07011160b79654bf
-Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
----
- src/quicktemplates2/qquickpopup.cpp | 1 +
- src/quicktemplates2/qquickpopuppositioner.cpp | 14 +++++++-------
- 3 files changed, 17 insertions(+), 15 deletions(-)
-
-diff --git a/src/quicktemplates2/qquickpopup.cpp b/src/quicktemplates2/qquickpopup.cpp
-index ecb2568ed..d108420ea 100644
---- a/src/quicktemplates2/qquickpopup.cpp
-+++ b/src/quicktemplates2/qquickpopup.cpp
-@@ -471,6 +471,7 @@ void QQuickPopupPrivate::finalizeEnterTransition()
- if (focus)
- popupItem->setFocus(true);
- transitionState = NoTransition;
-+ getPositioner()->reposition();
- emit q->openedChanged();
- emit q->opened();
- }
-diff --git a/src/quicktemplates2/qquickpopuppositioner.cpp b/src/quicktemplates2/qquickpopuppositioner.cpp
-index ebd8ff294..dbe8ac1d5 100644
---- a/src/quicktemplates2/qquickpopuppositioner.cpp
-+++ b/src/quicktemplates2/qquickpopuppositioner.cpp
-@@ -108,10 +108,11 @@ void QQuickPopupPositioner::reposition()
- return;
- }
-
-- const qreal w = popupItem->width();
-- const qreal h = popupItem->height();
-- const qreal iw = popupItem->implicitWidth();
-- const qreal ih = popupItem->implicitHeight();
-+ const qreal scale = popupItem->scale();
-+ const qreal w = popupItem->width() * scale;
-+ const qreal h = popupItem->height() * scale;
-+ const qreal iw = popupItem->implicitWidth() * scale;
-+ const qreal ih = popupItem->implicitHeight() * scale;
-
- bool widthAdjusted = false;
- bool heightAdjusted = false;
-@@ -257,10 +258,9 @@ void QQuickPopupPositioner::reposition()
- }
-
- if (!p->hasWidth && widthAdjusted && rect.width() > 0)
-- popupItem->setWidth(rect.width());
-+ popupItem->setWidth(rect.width() / scale);
- if (!p->hasHeight && heightAdjusted && rect.height() > 0)
-- popupItem->setHeight(rect.height());
--
-+ popupItem->setHeight(rect.height() / scale);
- m_positioning = false;
- }
-
---
-2.16.3
diff --git a/dev-qt/qtquickcontrols2/qtquickcontrols2-5.14.2-r1.ebuild b/dev-qt/qtquickcontrols2/qtquickcontrols2-5.14.2-r1.ebuild
deleted file mode 100644
index 05d48cade927..000000000000
--- a/dev-qt/qtquickcontrols2/qtquickcontrols2-5.14.2-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit qt5-build
-
-DESCRIPTION="Set of next generation Qt Quick controls for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-fi
-
-IUSE="widgets"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}
- widgets? ( ~dev-qt/qtwidgets-${PV} )
-"
-RDEPEND="${DEPEND}
- ~dev-qt/qtgraphicaleffects-${PV}
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-account-for-scale-before-positioning.patch" # QTBUG-73687
-)
-
-src_prepare() {
- qt_use_disable_mod widgets widgets \
- src/imports/platform/platform.pro
-
- qt5-build_src_prepare
-}