summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 11:52:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-06 12:24:41 +0200
commit3b11b1c8844f17fd7f46fa10256b355317dc3a46 (patch)
tree3485743d2ab92535f66734aae79382c94e83149f /dev-qt/qtscript
parentmedia-libs/avidemux-plugins: Drop 2.6.20 (diff)
downloadgentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.gz
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.tar.bz2
gentoo-3b11b1c8844f17fd7f46fa10256b355317dc3a46.zip
dev-qt: Add Qt 5.12.4
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtscript')
-rw-r--r--dev-qt/qtscript/Manifest1
-rw-r--r--dev-qt/qtscript/qtscript-5.12.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-qt/qtscript/Manifest b/dev-qt/qtscript/Manifest
index 5a2d3710021f..ae2775e60eeb 100644
--- a/dev-qt/qtscript/Manifest
+++ b/dev-qt/qtscript/Manifest
@@ -1 +1,2 @@
DIST qtscript-everywhere-src-5.12.3.tar.xz 2674896 BLAKE2B 9f655989505c288d22c9d961e79227cee84ce4d91f6a61b7038e3b993da6f610c3703ad24b2146931c7d46b1765b60f73af8adea6d55823d0b973a99b61adac8 SHA512 4c4498acb39536bdc03643fb1717c7a47c82b1734cf67d17d40bc216084f01e837648d261f7f69e317387f9c6efa9aaa6b0df8f5532f55615252c95b1089ca1a
+DIST qtscript-everywhere-src-5.12.4.tar.xz 2675028 BLAKE2B 7cae53222aa776992c54635b9590b2eea7504905d033266b7f6bc18bea4a8bc74e0714f37ba3e0fba022c2b22d4e93982cb370311e25d9fdd7a1ac5f43110e80 SHA512 6d3b802c7cdfb270318b9210df4ad9dbd2d29f485d9194051dbf278a48c25cc5c6311adeaf56b4fe2a7746dbc10234544e75e61a2e9c86f653aed0a92e07e717
diff --git a/dev-qt/qtscript/qtscript-5.12.4.ebuild b/dev-qt/qtscript/qtscript-5.12.4.ebuild
new file mode 100644
index 000000000000..c5092df8b111
--- /dev/null
+++ b/dev-qt/qtscript/qtscript-5.12.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE="+jit scripttools"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ scripttools? (
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod scripttools widgets \
+ src/src.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ JAVASCRIPTCORE_JIT=$(usex jit 'yes' 'no')
+ )
+ qt5-build_src_configure
+}