summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 22:35:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 23:40:47 +0100
commita663ab344d4deebd60dc35994eb659579412754d (patch)
treea5bf169a05fe2b3452a93f75cc460c51a61b44c4 /dev-qt/qtwayland
parentdev-db/redis: drop to ~hppa (diff)
downloadgentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.gz
gentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.bz2
gentoo-a663ab344d4deebd60dc35994eb659579412754d.zip
dev-qt: Add Qt 5.15.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 6660cc90db89..db82abff1152 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
DIST qtwayland-everywhere-src-5.15.1.tar.xz 563508 BLAKE2B 507e8612a35c6439fab0637edfcae95d712daf19c0a8b97110b57b8a8ffd70374addc3ef19f210eedc9493d84ec441f18bd0fd5a25af5394fde40ee55573eb09 SHA512 d6619f35b3ab163372a0d49a2221c487d5936b6d9ebeb92a7fd41521c424d550eea7c5c584e07f15bde1ec5ece1bd5774845eb9956ce793e546197ffdb28d594
+DIST qtwayland-everywhere-src-5.15.2.tar.xz 564884 BLAKE2B 472effd3e9f3fd5470e0449703a52d45f2fd823770880b5ad15d8bf99196eee5d8511ca2bc9e23df6e27c933551d1853928ba79b4b1e5fa6e53334c54c04a463 SHA512 e8657ed676873da7b949e6a1605d025918a03336af9c68f32741945ec3c71a604def55bb00737ba4d97b91c00d0e2df1a83cdcedcf5795c6b2a1ef2caa21c91c
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2.ebuild
new file mode 100644
index 000000000000..e292407158a9
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ ~dev-qt/qtgui-${PV}[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}