summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 11:18:34 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-26 16:32:27 +0200
commitaeb61e1abdbb629279cb188180567a3fb957d9e5 (patch)
tree1425b69473c31cd902abba3a496763dd2a325396 /dev-qt/qtwayland
parentqt5-build.eclass: Drop pre-Qt 5.14 quirks (diff)
downloadgentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.gz
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.tar.bz2
gentoo-aeb61e1abdbb629279cb188180567a3fb957d9e5.zip
dev-qt: Add Qt 5.15.0 release
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index fdfc49103e9c..0abc3d6da174 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-everywhere-src-5.14.1.tar.xz 544744 BLAKE2B cc74e6ac4519484713795169a91f18ed2535684bf604d12ab900a0fb2502d30c1fa4fbdc5899c4a32505e8f4b2be142d3b16540b6797c1624deac097d45ea41d SHA512 6cdfb527ce8160b562343bfb3959dfcd8ccc91a50817756547f4a0559b77372bee7587bc2e4e658e15b58ecb52c6eb0ef2193e30a285d13c4192bb03a1149cfc
DIST qtwayland-everywhere-src-5.14.2.tar.xz 544532 BLAKE2B 13cf07116737ec2fd301f51f517cbc062fdd42b800d6d2739193f3570f1a9552e66e9909de15c22cc530d5284c3be9ff24915ce4b36f529ec6c22faeb0edff58 SHA512 0f396cabace17f099c2f2c0be54317006dc00c5f4be08cd79a4fa4fdc94362f63cc6ce9decc7feb63f566dd2ea52d562257e4bb23332557054418fc16dc7e899
+DIST qtwayland-everywhere-src-5.15.0.tar.xz 562408 BLAKE2B ef3074dbf41be2a8545e3403c7cd0058067c2d4200323b0c0959024d581e6ccdb8765b448266aee082a67e8fc834fdea0459ec36822446abe970d66b3175980f SHA512 e3d8fb79b7d3b10a94caccca1567c3a978b3517e13740aa6218d0a0b4cb180f6bdc3b533e113248908033f344ab5fcffd6fac751a1513c2d62834afe408ee714
diff --git a/dev-qt/qtwayland/qtwayland-5.15.0.ebuild b/dev-qt/qtwayland/qtwayland-5.15.0.ebuild
new file mode 100644
index 000000000000..e292407158a9
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ ~dev-qt/qtgui-${PV}[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}