summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-17 22:53:59 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-21 12:03:38 +0100
commit306e84ca300c4f966a046db7d40bc4c6167e965d (patch)
tree9b65624b42916aac7c5833c1447819b83f65d86e /dev-qt/qtwaylandscanner
parentdev-qt/qtxmlpatterns: 5.15.3 version bump (diff)
downloadgentoo-306e84ca300c4f966a046db7d40bc4c6167e965d.tar.gz
gentoo-306e84ca300c4f966a046db7d40bc4c6167e965d.tar.bz2
gentoo-306e84ca300c4f966a046db7d40bc4c6167e965d.zip
dev-qt/qtwaylandscanner: New package, version 5.15.3
Split out of dev-qt/qtwayland. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwaylandscanner')
-rw-r--r--dev-qt/qtwaylandscanner/Manifest1
-rw-r--r--dev-qt/qtwaylandscanner/metadata.xml12
-rw-r--r--dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.3.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtwaylandscanner/Manifest b/dev-qt/qtwaylandscanner/Manifest
new file mode 100644
index 000000000000..bdddd1c73cff
--- /dev/null
+++ b/dev-qt/qtwaylandscanner/Manifest
@@ -0,0 +1 @@
+DIST qtwayland-everywhere-opensource-src-5.15.3.tar.xz 565004 BLAKE2B bc146caf77d42436dcb599df8d2aea422ac8717151dee91b9be129b97902d5af274dec90bd5ffceef62512515e5cf57a61ab773cfc6c13742a6cc5d9b6f72726 SHA512 0a9768282170709050490fb1b9daef59c21c8b5c4785f56a452d7954ffb6f016ec836022693941c99c5c10b2c3c55c75ba37fdad09dd1e0cde627f8b87b90c89
diff --git a/dev-qt/qtwaylandscanner/metadata.xml b/dev-qt/qtwaylandscanner/metadata.xml
new file mode 100644
index 000000000000..a1a4e61d01d9
--- /dev/null
+++ b/dev-qt/qtwaylandscanner/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>https://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.3.ebuild b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.3.ebuild
new file mode 100644
index 000000000000..1d586e6847cf
--- /dev/null
+++ b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qtwayland"
+inherit qt5-build
+
+DESCRIPTION="Tool that generates certain boilerplate C++ code from Wayland protocol xml spec"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*:5="
+RDEPEND="${DEPEND}
+ !<dev-qt/qtwayland-5.15.3:5
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtwaylandscanner
+)