summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild')
-rw-r--r--dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild b/dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild
new file mode 100644
index 000000000000..78f4e0ed9d6b
--- /dev/null
+++ b/dev-qt/qtwebkit/qtwebkit-4.8.6-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-build-multilib
+
+DESCRIPTION="The WebKit module for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS="arm ia64 ppc ppc64"
+else
+ KEYWORDS="amd64 arm ia64 ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+IUSE="+gstreamer icu +jit"
+
+# libxml2[!icu?] is needed for bugs 407315 and 411091
+DEPEND="
+ >=dev-db/sqlite-3.8.3:3[${MULTILIB_USEDEP}]
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,ssl,${MULTILIB_USEDEP}]
+ ~dev-qt/qtgui-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ ~dev-qt/qtxmlpatterns-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.5.0-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrender-0.9.7-r1[${MULTILIB_USEDEP}]
+ gstreamer? (
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:2[!icu?,${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-0.10.36-r1:0.10[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-0.10.36-r1:0.10[${MULTILIB_USEDEP}]
+ )
+ icu? ( dev-libs/icu:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/4.8.2-javascriptcore-x32.patch"
+)
+
+QT4_TARGET_DIRECTORIES="
+ src/3rdparty/webkit/Source/JavaScriptCore
+ src/3rdparty/webkit/Source/WebCore
+ src/3rdparty/webkit/Source/WebKit/qt"
+
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ # Remove -Werror from CXXFLAGS
+ sed -i -e '/QMAKE_CXXFLAGS\s*+=/ s:-Werror::g' \
+ src/3rdparty/webkit/Source/WebKit.pri || die
+
+ # Fix version number in generated pkgconfig file (bug 406443)
+ sed -i -e 's/^isEmpty(QT_BUILD_TREE)://' \
+ src/3rdparty/webkit/Source/WebKit/qt/QtWebKit.pro || die
+
+ # Prevent automagic dependency on qt-mobility (bug 547350)
+ sed -i -e 's/contains(MOBILITY_CONFIG,\s*\w\+)/false/' \
+ src/3rdparty/webkit/Source/WebCore/features.pri || die
+
+ if use icu; then
+ sed -i -e '/CONFIG\s*+=\s*text_breaking_with_icu/ s:^#\s*::' \
+ src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pri || die
+ fi
+
+ qt4-build-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ -webkit
+ -system-sqlite
+ $(qt_use icu)
+ $(qt_use jit javascript-jit)
+ $(use gstreamer || echo -DENABLE_VIDEO=0)
+ )
+ qt4_multilib_src_configure
+}