summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-03 08:06:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-03 08:09:14 +0200
commitea2ae777d028e584cd175b2d4081dea826c8f7d1 (patch)
treea686c99e0b2f854a51e106884aad5e0b1087c182 /dev-qt/qtwebkit
parentnet-libs/libtorrent: Fix configure checks to allow cross compiling (diff)
downloadgentoo-ea2ae777d028e584cd175b2d4081dea826c8f7d1.tar.gz
gentoo-ea2ae777d028e584cd175b2d4081dea826c8f7d1.tar.bz2
gentoo-ea2ae777d028e584cd175b2d4081dea826c8f7d1.zip
dev-qt/qtwebkit: 5.212.0_pre20180120 snapshot bump
Closes: https://bugs.gentoo.org/624404 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtwebkit')
-rw-r--r--dev-qt/qtwebkit/Manifest1
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-functional.patch22
-rw-r--r--dev-qt/qtwebkit/metadata.xml1
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild141
4 files changed, 165 insertions, 0 deletions
diff --git a/dev-qt/qtwebkit/Manifest b/dev-qt/qtwebkit/Manifest
index 97b9f0eada01..36eb87329b04 100644
--- a/dev-qt/qtwebkit/Manifest
+++ b/dev-qt/qtwebkit/Manifest
@@ -1 +1,2 @@
+DIST qtwebkit-5.212.0_pre20180120.tar.gz 18830192 BLAKE2B a74329c424f5546cbbfda8f398da8547a78661c66e26e8168ba2fc35140070cbd0e826aeadc6b4f1b30ef3f8dc5259a017fb4cb73990b1f03ed541afcab50ec0 SHA512 582b0c5cb10756d88206a9b935a868026f2c2294c6476c0668ad416880b921735efbad32635671daa89792ba9a6d4ff397534df150fe641d984d5784ce0bf047
DIST qtwebkit-opensource-src-5.9.1.tar.xz 35300628 BLAKE2B eb64f6345e14698d176958faccf7493073e177ac8c2e25b44f02c09df6b45e4a069e2c86960d9fbe497f7d59099b25d021743437276c1bd6bc8fd0593052faa2 SHA512 79316ab746a230fdb290e28629d7cec5fca75119ba8868060742c682ab86490de9ffd8e517569aa7412f35fd709568dbb5f7d2d467bdb4461e192f8b05d6f1e5
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-functional.patch b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-functional.patch
new file mode 100644
index 000000000000..d8b5ba6cf31e
--- /dev/null
+++ b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20180120-functional.patch
@@ -0,0 +1,22 @@
+From 4ce8ebc4094512b9916bfa5984065e95ac97c9d8 Mon Sep 17 00:00:00 2001
+From: Konstantin Tokarev <annulen@yandex.ru>
+Date: Fri, 26 Jan 2018 20:50:07 +0300
+Subject: [PATCH] Add missing #include <functional>
+
+Change-Id: Ic5499c1854479064b735bff79b3501992a20a12f
+---
+ Source/WebCore/dom/SlotAssignment.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/WebCore/dom/SlotAssignment.h b/Source/WebCore/dom/SlotAssignment.h
+index 0fcd4dfa6de8..9b9ebe429816 100644
+--- a/Source/WebCore/dom/SlotAssignment.h
++++ b/Source/WebCore/dom/SlotAssignment.h
+@@ -28,6 +28,7 @@
+
+ #if ENABLE(SHADOW_DOM) || ENABLE(DETAILS_ELEMENT)
+
++#include <functional>
+ #include <wtf/HashMap.h>
+ #include <wtf/HashSet.h>
+ #include <wtf/Vector.h>
diff --git a/dev-qt/qtwebkit/metadata.xml b/dev-qt/qtwebkit/metadata.xml
index 645be81df281..c7df499ff74f 100644
--- a/dev-qt/qtwebkit/metadata.xml
+++ b/dev-qt/qtwebkit/metadata.xml
@@ -9,6 +9,7 @@
<flag name="geolocation">Enable physical position determination via <pkg>dev-qt/qtpositioning</pkg></flag>
<flag name="gles2">Use GLES 2.0 or later instead of full OpenGL</flag>
<flag name="gstreamer">Enable HTML5 audio/video support via <pkg>media-libs/gstreamer</pkg> using SLOT 1.0</flag>
+ <flag name="hyphen">Enable hyphenation support via <pkg>dev-libs/hyphen</pkg></flag>
<flag name="multimedia">Enable HTML5 audio/video support via <pkg>dev-qt/qtmultimedia</pkg></flag>
<flag name="orientation">Enable device orientation detection via <pkg>dev-qt/qtsensors</pkg></flag>
<flag name="printsupport">Enable printing via <pkg>dev-qt/qtprintsupport</pkg></flag>
diff --git a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild
new file mode 100644
index 000000000000..506e3879d340
--- /dev/null
+++ b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20180120.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=72cfbd7664f21fcc0e62b869a6b01bf73eb5e7da
+CMAKE_MAKEFILE_GENERATOR="ninja"
+PYTHON_COMPAT=( python2_7 )
+USE_RUBY="ruby23 ruby24 ruby25"
+inherit check-reqs cmake-utils flag-o-matic python-any-r1 qmake-utils ruby-single toolchain-funcs
+
+DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
+HOMEPAGE="https://www.qt.io/"
+SRC_URI="http://code.qt.io/cgit/qt/${PN}.git/snapshot/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD LGPL-2+"
+SLOT="5/5.212"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="geolocation gles2 +gstreamer +hyphen +jit multimedia nsplugin opengl orientation +printsupport qml webp X"
+
+REQUIRED_USE="
+ nsplugin? ( X )
+ qml? ( opengl )
+ ?? ( gstreamer multimedia )
+"
+
+QT_MIN_VER="5.9.1:5"
+# Dependencies found at Source/cmake/OptionsQt.cmake
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/icu:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-qt/qtcore-${QT_MIN_VER}
+ >=dev-qt/qtgui-${QT_MIN_VER}
+ >=dev-qt/qtnetwork-${QT_MIN_VER}
+ >=dev-qt/qtwidgets-${QT_MIN_VER}
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ geolocation? ( >=dev-qt/qtpositioning-${QT_MIN_VER} )
+ gstreamer? (
+ dev-libs/glib:2
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-bad:1.0
+ )
+ hyphen? ( dev-libs/hyphen )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_MIN_VER}[widgets] )
+ opengl? (
+ >=dev-qt/qtgui-${QT_MIN_VER}[gles2=]
+ >=dev-qt/qtopengl-${QT_MIN_VER}
+ )
+ orientation? ( >=dev-qt/qtsensors-${QT_MIN_VER} )
+ printsupport? ( >=dev-qt/qtprintsupport-${QT_MIN_VER} )
+ qml? (
+ >=dev-qt/qtdeclarative-${QT_MIN_VER}
+ >=dev-qt/qtwebchannel-${QT_MIN_VER}[qml]
+ )
+ webp? ( media-libs/libwebp:0= )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXrender
+ )
+"
+
+# Need real bison, not yacc
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ ${RUBY_DEPS}
+ dev-lang/perl
+ dev-util/gperf
+ >=sys-devel/bison-2.4.3
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+CHECKREQS_DISK_BUILD="16G" # Debug build requires much more see bug #417307
+
+S="${WORKDIR}/${COMMIT}"
+
+PATCHES=( "${FILESDIR}/${P}-functional.patch" )
+
+_check_reqs() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+}
+
+pkg_pretend() {
+ _check_reqs
+}
+
+pkg_setup() {
+ _check_reqs
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # Multiple rendering bugs on youtube, github, etc without this, bug #547224
+ append-flags $(test-flags -fno-strict-aliasing)
+
+ local mycmakeargs=(
+ -DPORT=Qt
+ -DENABLE_API_TESTS=OFF
+ -DENABLE_GEOLOCATION=$(usex geolocation)
+ -DUSE_GSTREAMER=$(usex gstreamer)
+ -DENABLE_JIT=$(usex jit)
+ -DUSE_QT_MULTIMEDIA=$(usex multimedia)
+ -DENABLE_NETSCAPE_PLUGIN_API=$(usex nsplugin)
+ -DENABLE_OPENGL=$(usex opengl)
+ -DENABLE_DEVICE_ORIENTATION=$(usex orientation)
+ -DENABLE_WEBKIT2=$(usex qml)
+ $(cmake-utils_use_find_package webp WebP)
+ -DENABLE_X11_TARGET=$(usex X)
+ )
+
+ if has_version "virtual/rubygems[ruby_targets_ruby25]"; then
+ mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby25) )
+ elif has_version "virtual/rubygems[ruby_targets_ruby24]"; then
+ mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby24) )
+ else
+ mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby23) )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # bug 572056
+ if [[ ! -f ${D%/}$(qt5_get_libdir)/libQt5WebKit.so ]]; then
+ eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
+ die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
+ fi
+}