summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-23 13:29:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-23 17:59:33 +0100
commit29169b91a0889d8d57a86c15e189cd318e1498d3 (patch)
tree4d44a64b717fb7bf295e516cafc7c532b428624e /dev-qt
parentwww-client/otter: unkeyword 1.0.03-r1 for ~ppc64 (diff)
downloadgentoo-29169b91a0889d8d57a86c15e189cd318e1498d3.tar.gz
gentoo-29169b91a0889d8d57a86c15e189cd318e1498d3.tar.bz2
gentoo-29169b91a0889d8d57a86c15e189cd318e1498d3.zip
dev-qt/assistant: 5.15.13 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/assistant/Manifest2
-rw-r--r--dev-qt/assistant/assistant-5.15.13.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/assistant/Manifest b/dev-qt/assistant/Manifest
index 61e076d3335a..1cc68e40f8f1 100644
--- a/dev-qt/assistant/Manifest
+++ b/dev-qt/assistant/Manifest
@@ -1,2 +1,4 @@
DIST qttools-5.15.12-gentoo-kde-1.tar.xz 3940 BLAKE2B 63dd5fb92d6ac9aeb2aa4015033067a6cee9b2f662fed54d7d699210ceb29bf15d11f6fbb2ace2eecb1a43a1b310a6f853f056fa03adb50722de49783b906556 SHA512 d0b0f614e244728789e8fee5390efd7380980c396b1b674f10ec488565921b5662e3d65b542c077093ba4a9a5ef49aee085a8cb258040527ac800c7878e0e484
+DIST qttools-5.15.13-gentoo-kde-1.tar.xz 3948 BLAKE2B 081e5d9fa81809545a15da707c58eb3754672f68084c8514282f7edbea3f469b681c003da9e59053d7f5654883ca06769cf46398461930f6222bb3ed86758522 SHA512 8afc3f763732a40e7e827de339395b4398b84bc2b2c0749f96f3cf6afdc655ba59b94809658f16d975eed63c28fd2b2b4f96b9b50fda251c2a1d085ed3c1cd15
DIST qttools-everywhere-opensource-src-5.15.12.tar.xz 8900672 BLAKE2B 897e05d8de54b50b47262d1b2606d78d2591bda1d7d4bf9e5d3be084a9a8156da3b8ec7e3b95b44e58e9a94562068b24129844ab1330426ec9b1a00d1409cd92 SHA512 d830129777c481e1a66e32911af82a09e2858b678fdd2b802433fc1009856d9f0b8ea39b6ed1d7e93b6e9db1dda848c3a4077f6d804400f1427f33a3c7ccb40e
+DIST qttools-everywhere-opensource-src-5.15.13.tar.xz 8897928 BLAKE2B cd4743e5cf8f444f8d8d8cd971eedd727ea7e7d8c3d237e61222cece0c0d10cb5090bba4db2f9c6a8dabfb0002eb21d58fe1c9aa916188d29e58f04ddfa24504 SHA512 a73abba58c76a69e2208c4228bf115f2ef6173db8fa00df9302eb4c8f04ff04b64690367c31a680dba3b0b8865ef27343e8d7343f7f81954c39458c443fd3500
diff --git a/dev-qt/assistant/assistant-5.15.13.ebuild b/dev-qt/assistant/assistant-5.15.13.ebuild
new file mode 100644
index 000000000000..d980696867be
--- /dev/null
+++ b/dev-qt/assistant/assistant-5.15.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
+
+IUSE=""
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*[png]
+ =dev-qt/qthelp-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtprintsupport-${QT5_PV}*
+ =dev-qt/qtsql-${QT5_PV}*[sqlite]
+ =dev-qt/qtwidgets-${QT5_PV}*
+"
+RDEPEND="${DEPEND}
+ !dev-qt/${PN}:5
+ !<dev-qt/qtchooser-66-r2
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/assistant
+)
+
+src_prepare() {
+ sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
+ -i src/assistant/assistant/assistant.pro || die
+
+ qt5-build_src_prepare
+}
+
+src_install() {
+ qt5-build_src_install
+ qt5_symlink_binary_to_path assistant
+
+ doicon -s 32 src/assistant/assistant/images/assistant.png
+ newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
+ make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}