summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 07:24:52 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:37 -0400
commit70278361e36d5b280731836b0a6cab34a5c2c819 (patch)
tree9d12273d13517ebd65db5dd455c25eaeee854d5c /dev-qt
parentdev-qt/qtwebview: add 6.7.0_rc (diff)
downloadgentoo-70278361e36d5b280731836b0a6cab34a5c2c819.tar.gz
gentoo-70278361e36d5b280731836b0a6cab34a5c2c819.tar.bz2
gentoo-70278361e36d5b280731836b0a6cab34a5c2c819.zip
dev-qt/qtvirtualkeyboard: skip tst_layoutfilesystem, drop -j1 (qt6)
Had this fail again despite -j1, then work the next, let's just skip. This was on a llvm-musl profile, unsure if related. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.2.ebuild10
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.9999.ebuild10
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0_rc.ebuild10
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild10
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild10
5 files changed, 35 insertions, 15 deletions
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.2.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.2.ebuild
index b0f29270f97d..c3faae0375db 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.2.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.2.ebuild
@@ -31,10 +31,15 @@ src_configure() {
}
src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
if use spell && has_version app-dicts/myspell-en; then
# 99% pass but minor sub-tests fail with myspell-en, needs looking into
ewarn "Warning: notable tests were skipped due to ${_} being installed"
- local CMAKE_SKIP_TESTS=(
+ CMAKE_SKIP_TESTS+=(
tst_inputpanel
tst_inputpanelcontrols2
)
@@ -42,6 +47,5 @@ src_test() {
einfo "tst_inputpanel can take >5mins, not known to actually hang"
fi
- # tst_layoutfilesystem seems to fail randomly without -j1
- qt6-build_src_test -j1
+ qt6-build_src_test
}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.9999.ebuild
index 4da95f48bdd5..f01f882be219 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.9999.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.6.9999.ebuild
@@ -31,10 +31,15 @@ src_configure() {
}
src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
if use spell && has_version app-dicts/myspell-en; then
# 99% pass but minor sub-tests fail with myspell-en, needs looking into
ewarn "Warning: notable tests were skipped due to ${_} being installed"
- local CMAKE_SKIP_TESTS=(
+ CMAKE_SKIP_TESTS+=(
tst_inputpanel
tst_inputpanelcontrols2
)
@@ -42,6 +47,5 @@ src_test() {
einfo "tst_inputpanel can take >5mins, not known to actually hang"
fi
- # tst_layoutfilesystem seems to fail randomly without -j1
- qt6-build_src_test -j1
+ qt6-build_src_test
}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0_rc.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0_rc.ebuild
index 4da95f48bdd5..f01f882be219 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0_rc.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.0_rc.ebuild
@@ -31,10 +31,15 @@ src_configure() {
}
src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
if use spell && has_version app-dicts/myspell-en; then
# 99% pass but minor sub-tests fail with myspell-en, needs looking into
ewarn "Warning: notable tests were skipped due to ${_} being installed"
- local CMAKE_SKIP_TESTS=(
+ CMAKE_SKIP_TESTS+=(
tst_inputpanel
tst_inputpanelcontrols2
)
@@ -42,6 +47,5 @@ src_test() {
einfo "tst_inputpanel can take >5mins, not known to actually hang"
fi
- # tst_layoutfilesystem seems to fail randomly without -j1
- qt6-build_src_test -j1
+ qt6-build_src_test
}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
index 4da95f48bdd5..f01f882be219 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
@@ -31,10 +31,15 @@ src_configure() {
}
src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
if use spell && has_version app-dicts/myspell-en; then
# 99% pass but minor sub-tests fail with myspell-en, needs looking into
ewarn "Warning: notable tests were skipped due to ${_} being installed"
- local CMAKE_SKIP_TESTS=(
+ CMAKE_SKIP_TESTS+=(
tst_inputpanel
tst_inputpanelcontrols2
)
@@ -42,6 +47,5 @@ src_test() {
einfo "tst_inputpanel can take >5mins, not known to actually hang"
fi
- # tst_layoutfilesystem seems to fail randomly without -j1
- qt6-build_src_test -j1
+ qt6-build_src_test
}
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
index 4da95f48bdd5..f01f882be219 100644
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
+++ b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.9999.ebuild
@@ -31,10 +31,15 @@ src_configure() {
}
src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # rarely randomly(?) fails even with -j1
+ tst_layoutfilesystem
+ )
+
if use spell && has_version app-dicts/myspell-en; then
# 99% pass but minor sub-tests fail with myspell-en, needs looking into
ewarn "Warning: notable tests were skipped due to ${_} being installed"
- local CMAKE_SKIP_TESTS=(
+ CMAKE_SKIP_TESTS+=(
tst_inputpanel
tst_inputpanelcontrols2
)
@@ -42,6 +47,5 @@ src_test() {
einfo "tst_inputpanel can take >5mins, not known to actually hang"
fi
- # tst_layoutfilesystem seems to fail randomly without -j1
- qt6-build_src_test -j1
+ qt6-build_src_test
}