summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-09 15:35:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-09 16:01:27 +0100
commitd1b4aabbd2e9aa198432c52288dabfa3f3d125c7 (patch)
treef5c498950fb61bc8a056adf8d4d36343df7602e8 /dev-qt
parentdev-python/pikepdf: Remove old (diff)
downloadgentoo-d1b4aabbd2e9aa198432c52288dabfa3f3d125c7.tar.gz
gentoo-d1b4aabbd2e9aa198432c52288dabfa3f3d125c7.tar.bz2
gentoo-d1b4aabbd2e9aa198432c52288dabfa3f3d125c7.zip
dev-qt/qtwayland: Prevent Wayland context menus can go offscreen
- Client: Remove flip popup constraints - client: set_constraint_adjustment() for popups in xdg QTBUG: https://bugreports-test.qt.io/browse/QTBUG-87303 Bug: https://bugs.gentoo.org/900358 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.8-r3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 2ca7d17bc2a6..474f44b7ff2f 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,4 +1,5 @@
DIST qtwayland-5.15.8-gentoo-kde-1.tar.xz 44488 BLAKE2B bfdd7c2959eb99e115eaf01d617464359a549513958c997dd8b1a86bda755dec44d24b6619650bf385b2894a2001a712a344b093fc94e8cde40ac9c20323903e SHA512 3cd52fc78f2451c38c6d2b0dd958895016a94b255e38ff3909f40e4bcb1ef760332fde4cffd32ab11e868ce0afe6629f325613c88b8fd85ca28f1583194ce229
DIST qtwayland-5.15.8-gentoo-kde-2.tar.xz 46592 BLAKE2B 0f2c460038a5b6f6fb7ea38edf61b392e95caa6356e8c070bde9d7939e20aaee4a45a581e08d04ad34f2a2da6317c2a16c40e58272d0c256fd16f0a1ce6fa34a SHA512 8b6c94e032a35f6ec6400fa292b1c7b864504d5c94d095c20fd41da8576eab4325bf7312b08cca00825aa858e175510b8b37c5877207fb4d60edde99c77c9886
+DIST qtwayland-5.15.8-gentoo-kde-3.tar.xz 47636 BLAKE2B b57cef6d4ce70747b74062e26459e4957c8df2c1c588b00580e175982b09c8cf172968d4d0bc95576e0e76f2640188d3beef4986d33ef4b79d209bf4a4cdbb45 SHA512 bd23c644f6e957ce7c0aacbe08112deb992608f5546889f765b333fc6094e34bc7329859d66bfbdbd56ebb5d77b82958ff3fc6614780c80573e85bb96f59eae6
DIST qtwayland-everywhere-opensource-src-5.15.8.tar.xz 568268 BLAKE2B b4e982015e25104b3270b48a180b5726ba85e83fd9616422422d8729dc09bc94bbeecfe2096e388eadb0930e4abfdd3b0349eba2bd1d8f742f0c74b5e72aeac5 SHA512 6c6e9dc20f98d71abd7dba54ff278bf4535e70f86bfc4e6dd46c1af7c87777f045a6aba02bba3eb786f7cf383da5fb72b03e1e6ec636c8be0cde0e4e5b7b5b2d
DIST qtwayland-everywhere-src-6.4.2.tar.xz 836720 BLAKE2B d8a6b84712081097775f083f3887c18eb001fd2beba32b2abc930ec3b932f6f19b347fe2fde3b98f35c1e7e31661974b13468fb176e73bdf557a330c80d847fd SHA512 29d3f3e7fade666bcd3145106f1d782122ac3fcf94811d25917c9f45af0dc8cddb3c2149545344d91e86f86490029555758ed2e180f241703251c22c7ec15122
diff --git a/dev-qt/qtwayland/qtwayland-5.15.8-r3.ebuild b/dev-qt/qtwayland/qtwayland-5.15.8-r3.ebuild
new file mode 100644
index 000000000000..2c0b9e5c9e3b
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.8-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=3
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}
+
+src_install() {
+ qt5-build_src_install
+ rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
+}