summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-09 21:44:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-10 19:52:30 +0200
commitda0505d7b983832b3d6c981a30cc8984d153a5ac (patch)
tree1ee434716b7683f0c2251340bca46f9f2a29bd5f /dev-qt
parentdev-qt/qtmultimedia: Gstreamer: fix stream buffering (diff)
downloadgentoo-da0505d7b983832b3d6c981a30cc8984d153a5ac.tar.gz
gentoo-da0505d7b983832b3d6c981a30cc8984d153a5ac.tar.bz2
gentoo-da0505d7b983832b3d6c981a30cc8984d153a5ac.zip
dev-qt/qtdeclarative: Fix QQuickMouseArea get stuck in pressed state
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch55
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.14.2-r3.ebuild59
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch b/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch
new file mode 100644
index 000000000000..1dd0ff1155de
--- /dev/null
+++ b/dev-qt/qtdeclarative/files/qtdeclarative-5.14.2-QQuickMouseArea-stuck-in-pressed-state.patch
@@ -0,0 +1,55 @@
+From 8ace780b5aa298e3c01903bfd57f766a42209191 Mon Sep 17 00:00:00 2001
+From: Frederik Gladhorn <frederik.gladhorn@remarkable.com>
+Date: Sat, 28 Mar 2020 15:14:41 +0100
+Subject: [PATCH] Fix QQuickMouseArea getting stuck in pressed state when
+ hiding in press
+MIME-Version: 1.0
+Content-Type: text/plain; charset=utf8
+Content-Transfer-Encoding: 8bit
+
+In 78c1fcbc49f56463064eef738a475d9018357b24 we stopped giving the
+exclusive grab to hidden or disabled items with is good. But the change
+did not take into consideration how mouse area handles its internal
+state.
+
+As a simple example: A mouse area that would set itself hiddin in the
+press handler, would continue to have d->pressed == true, which means it
+would not react to any future press events.
+
+The fix is to let mouse area check in its change handler whether it has
+become invisible.
+The test also checks that enabled behaves the same way. There is no
+action needed, since mouse area does completely custom handling of
+enabled (maybe something to fix in Qt 6), disabling a mouse area doesn't
+disable its children for example, it doesn't invoke
+QQuickItem::setEnabled at all. Due to this circumventing the common
+behavior, by chance disabling a mouse area in the on pressed handler
+works.
+
+Fixes: QTBUG-74987
+Change-Id: Idb8499b3e5bcb744fbba203fdea5c46695bd5077
+Reviewed-by: Jan Arve Sæther <jan-arve.saether@qt.io>
+---
+ src/quick/items/qquickmousearea.cpp | 6 ++++
+ 3 files changed, 80 insertions(+)
+ create mode 100644 tests/auto/quick/qquickmousearea/data/settingHiddenInPressUngrabs.qml
+
+diff --git a/src/quick/items/qquickmousearea.cpp b/src/quick/items/qquickmousearea.cpp
+index 368379f5c40..dc60712a9cd 100644
+--- a/src/quick/items/qquickmousearea.cpp
++++ b/src/quick/items/qquickmousearea.cpp
+@@ -1083,6 +1083,12 @@ void QQuickMouseArea::itemChange(ItemChange change, const ItemChangeData &value)
+ }
+ setHovered(!d->hovered);
+ }
++ if (d->pressed && (!isVisible())) {
++ // This happens when the mouse area sets itself disabled or hidden
++ // inside the press handler. In that case we should not keep the internal
++ // state as pressed, since we never became the mouse grabber.
++ ungrabMouse();
++ }
+ break;
+ default:
+ break;
+--
+2.16.3
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r3.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r3.ebuild
new file mode 100644
index 000000000000..71250b4c877d
--- /dev/null
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.14.2-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2009-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1 qt5-build
+
+DESCRIPTION="The QML and Quick modules for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="gles2-only +jit localstorage vulkan +widgets"
+
+BDEPEND="${PYTHON_DEPS}"
+# qtgui[gles2-only=] is needed because of bug 504322
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2-only=,vulkan=]
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qttest-${PV}
+ localstorage? ( ~dev-qt/qtsql-${PV} )
+ widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
+"
+RDEPEND="${DEPEND}
+ !<dev-qt/qtquickcontrols-5.7:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
+ "${FILESDIR}/${P}-fix-subpixel-positioned-text.patch" # QTBUG-49646
+ "${FILESDIR}/${P}-QQuickMouseArea-stuck-in-pressed-state.patch" # QTBUG-74987
+)
+
+src_prepare() {
+ use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
+
+ qt_use_disable_mod localstorage sql \
+ src/imports/imports.pro
+
+ qt_use_disable_mod widgets widgets \
+ src/src.pro \
+ src/qmltest/qmltest.pro \
+ tests/auto/auto.pro \
+ tools/tools.pro \
+ tools/qmlscene/qmlscene.pro \
+ tools/qml/qml.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ -qml-debug
+ )
+ qt5-build_src_configure
+}