summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 17:31:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:16 +0100
commite575c32b7bc4514e753ec9c35e193cfd73596ea5 (patch)
tree8eae70010e8be572ca52e09fffc6683f7a8faf2f /dev-ros/actionlib
parentdev-ros/actionlib: Remove old (diff)
downloadgentoo-e575c32b7bc4514e753ec9c35e193cfd73596ea5.tar.gz
gentoo-e575c32b7bc4514e753ec9c35e193cfd73596ea5.tar.bz2
gentoo-e575c32b7bc4514e753ec9c35e193cfd73596ea5.zip
dev-ros/actionlib: bump to 1.11.12
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/actionlib')
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.11.12.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
index 633a29423d83..2c301bfdbc6a 100644
--- a/dev-ros/actionlib/Manifest
+++ b/dev-ros/actionlib/Manifest
@@ -1 +1,2 @@
DIST actionlib-1.11.11.tar.gz 98427 BLAKE2B 2ec632d8266557c1c74d3b2de672728f53e0bac10bc0d0346d255d78ac59d39ac1d3cc2af157d67d5988a95f52f51dc57f3a0d5ccacca209b5a09ad44fee8f1c SHA512 a2a02abfb3e192082143d83ceab6a612f501bbd1ec38d108e3a841afb331d1a98e8a602fac7d627a62c336a52ffe70331d2001394b134511c89349567b49d83d
+DIST actionlib-1.11.12.tar.gz 98435 BLAKE2B f35a12b6628d1a3545a805ca924d71899583c2c67259b552681e4ec7f984e9d1b55df5b976d3d8787e51ffc4f193979ba08a13fee97aaf4826f7284a710cc041 SHA512 319150a7094d063770c2193edf8665fc52fc099620740dfe7cf033b1e445aedf55621c93284dd4a4c4f49f12a9e414f650a61d73a64cdd012945e27cfac16458
diff --git a/dev-ros/actionlib/actionlib-1.11.12.ebuild b/dev-ros/actionlib/actionlib-1.11.12.ebuild
new file mode 100644
index 000000000000..cb76b829848c
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"