summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 09:55:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 11:42:05 +0100
commit22c65396a95eb63f0a62e8478ef4da041ad213e5 (patch)
tree0995ca9e5ca01104cb6cfce0cc9a5643510584dd /dev-ros/amcl/files
parentdev-ros/mavlink-gbp-release: bump to 2019.11.11 (diff)
downloadgentoo-22c65396a95eb63f0a62e8478ef4da041ad213e5.tar.gz
gentoo-22c65396a95eb63f0a62e8478ef4da041ad213e5.tar.bz2
gentoo-22c65396a95eb63f0a62e8478ef4da041ad213e5.zip
dev-ros/amcl: really fix build with latest cmake
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/amcl/files')
-rw-r--r--dev-ros/amcl/files/cmake.patch3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-ros/amcl/files/cmake.patch b/dev-ros/amcl/files/cmake.patch
index 4ae817168925..da31fe79331d 100644
--- a/dev-ros/amcl/files/cmake.patch
+++ b/dev-ros/amcl/files/cmake.patch
@@ -2,10 +2,11 @@ Index: amcl/CMakeLists.txt
===================================================================
--- amcl.orig/CMakeLists.txt
+++ amcl/CMakeLists.txt
-@@ -1,5 +1,6 @@
+@@ -1,5 +1,7 @@
cmake_minimum_required(VERSION 3.1)
project(amcl)
+include(CheckSymbolExists)
++include(CheckIncludeFile)
if(NOT CMAKE_CXX_STANDARD)
set(CMAKE_CXX_STANDARD 11)