summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:21 +0100
commit7b2bf6b9eefb2bff4ad024b66ee1b815b540e2cb (patch)
tree808f65ec9361093188fc7903753484627d7c184a /dev-ros/ament_cmake_gtest
parentdev-ros/ament_cmake_core: use python-any-r1 (diff)
downloadgentoo-7b2bf6b9eefb2bff4ad024b66ee1b815b540e2cb.tar.gz
gentoo-7b2bf6b9eefb2bff4ad024b66ee1b815b540e2cb.tar.bz2
gentoo-7b2bf6b9eefb2bff4ad024b66ee1b815b540e2cb.zip
dev-ros/ament_cmake_gtest: initial import
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_gtest')
-rw-r--r--dev-ros/ament_cmake_gtest/Manifest1
-rw-r--r--dev-ros/ament_cmake_gtest/ament_cmake_gtest-0.8.1.ebuild41
-rw-r--r--dev-ros/ament_cmake_gtest/ament_cmake_gtest-9999.ebuild41
-rw-r--r--dev-ros/ament_cmake_gtest/metadata.xml11
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_gtest/Manifest b/dev-ros/ament_cmake_gtest/Manifest
new file mode 100644
index 000000000000..ed522b74e133
--- /dev/null
+++ b/dev-ros/ament_cmake_gtest/Manifest
@@ -0,0 +1 @@
+DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
diff --git a/dev-ros/ament_cmake_gtest/ament_cmake_gtest-0.8.1.ebuild b/dev-ros/ament_cmake_gtest/ament_cmake_gtest-0.8.1.ebuild
new file mode 100644
index 000000000000..0987702da776
--- /dev/null
+++ b/dev-ros/ament_cmake_gtest/ament_cmake_gtest-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add gtest-based tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
diff --git a/dev-ros/ament_cmake_gtest/ament_cmake_gtest-9999.ebuild b/dev-ros/ament_cmake_gtest/ament_cmake_gtest-9999.ebuild
new file mode 100644
index 000000000000..0987702da776
--- /dev/null
+++ b/dev-ros/ament_cmake_gtest/ament_cmake_gtest-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add gtest-based tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
diff --git a/dev-ros/ament_cmake_gtest/metadata.xml b/dev-ros/ament_cmake_gtest/metadata.xml
new file mode 100644
index 000000000000..d1baaf5c70f1
--- /dev/null
+++ b/dev-ros/ament_cmake_gtest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_cmake</remote-id>
+ </upstream>
+</pkgmetadata>