summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:43:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:20 +0100
commit4e9ba7d7dbae385dac89ba682017993cc2fe1ddd (patch)
treeee8ec3f4956f73ebaf77867f372e1fff1acc0bc3 /dev-ros/ament_cmake_libraries
parentdev-ros/ament_cmake_python: use python-any-r1 (diff)
downloadgentoo-4e9ba7d7dbae385dac89ba682017993cc2fe1ddd.tar.gz
gentoo-4e9ba7d7dbae385dac89ba682017993cc2fe1ddd.tar.bz2
gentoo-4e9ba7d7dbae385dac89ba682017993cc2fe1ddd.zip
dev-ros/ament_cmake_libraries: use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_libraries')
-rw-r--r--dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
index 5e721bb81ef3..b38982c35672 100644
--- a/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}