summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:22:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:55:56 +0100
commit6aa0db9ab6b1bc250f2b85acece0b235f16b5886 (patch)
treea4f4978e77d92d2c163ba7bb0d65631fe7317be1 /dev-ros/bondpy
parentdev-ros/bondcpp: Bump to 1.7.17. (diff)
downloadgentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.tar.gz
gentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.tar.bz2
gentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.zip
dev-ros/bondpy: Bump to 1.7.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/bondpy')
-rw-r--r--dev-ros/bondpy/Manifest1
-rw-r--r--dev-ros/bondpy/bondpy-1.7.17.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/bondpy/Manifest b/dev-ros/bondpy/Manifest
index 0d7a60a51eaa..3db390ef0d1a 100644
--- a/dev-ros/bondpy/Manifest
+++ b/dev-ros/bondpy/Manifest
@@ -1 +1,2 @@
DIST bond_core-1.7.16.tar.gz 25327 SHA256 177dc78ef9cf3cd9f48fe5aca4742f504956c71641c75048b7559af0e2aacd53 SHA512 1c35776782edfb7397845fde0ef3fcaac6179f1c55637fd5209303feb1755f13bff85e6cf36a2dd2671c18d5b433cb8e9ede04df923f742e22934b19d044e06e WHIRLPOOL 56fd05d2c6c8f5fb9fa8b47f2da939e16f79f39937febbf588137d5dd411c03f0c30edb3e70b50ed4c6b7c1ce8a0f1cd8c1922038c20495e62a57c80d0958864
+DIST bond_core-1.7.17.tar.gz 31334 SHA256 41e511233510b6d8c73f354c2198c4ff5e82bafa47120fb3ffcb6704a2d7f1a6 SHA512 248146e6704c36f014e0f4c5178e566b6c4e344f46b39d4ac9a6cf6b152d1c163b5881921168b8898ec44da9d9b5bc69dc3a66ae26be61007c109aed1990ee73 WHIRLPOOL 2da1910eedc7b4af12c6172c01fd7fe60ad11645366e0b3e684c458b4f78a82b61f957c12d88f248cbc1aced57c4f97a2e1c6319c5a417a470fb1d0904ca66a9
diff --git a/dev-ros/bondpy/bondpy-1.7.17.ebuild b/dev-ros/bondpy/bondpy-1.7.17.ebuild
new file mode 100644
index 000000000000..abb50962dc64
--- /dev/null
+++ b/dev-ros/bondpy/bondpy-1.7.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/smclib
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"