summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commite28eaebb7a5c3bffed080812b537612c2bcd4569 (patch)
treeec0bc3abe102f47c7af204bba045a218852dc9d3 /dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
parentsci-physics/lammps: Version bump (diff)
downloadgentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.tar.gz
gentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.tar.bz2
gentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.zip
dev-ros/calibration_estimation: Bump to 0.10.14.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
new file mode 100644
index 000000000000..b6c1e6fcd36f
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-libs/urdfdom[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"