summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 11:21:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 11:44:13 +0200
commitb64574b823cbe710cc667c92318e591eebdccd4c (patch)
tree2239847d80804f73a6149408678e3297af2a404a /dev-ros/camera_info_manager/camera_info_manager-9999.ebuild
parentdev-ros/camera_calibration_parsers: Initial import. Ebuild by me. (diff)
downloadgentoo-b64574b823cbe710cc667c92318e591eebdccd4c.tar.gz
gentoo-b64574b823cbe710cc667c92318e591eebdccd4c.tar.bz2
gentoo-b64574b823cbe710cc667c92318e591eebdccd4c.zip
dev-ros/camera_info_manager: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/camera_info_manager/camera_info_manager-9999.ebuild')
-rw-r--r--dev-ros/camera_info_manager/camera_info_manager-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/camera_info_manager/camera_info_manager-9999.ebuild b/dev-ros/camera_info_manager/camera_info_manager-9999.ebuild
new file mode 100644
index 000000000000..5857f50e8f41
--- /dev/null
+++ b/dev-ros/camera_info_manager/camera_info_manager-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ interface for camera calibration information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration_parsers
+ dev-ros/image_transport
+ dev-ros/roscpp
+ dev-ros/roslib
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND} test? ( dev-ros/rostest )"