summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-12 13:51:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-12 13:59:44 +0200
commit20db7107edd0406ffa4e419def8df391048fb9cb (patch)
tree3d35eb30924d09c2184952f27226303e43f6647e /dev-ros/depth_image_proc
parentdev-ros/compressed_depth_image_transport: add missing boost dep (diff)
downloadgentoo-20db7107edd0406ffa4e419def8df391048fb9cb.tar.gz
gentoo-20db7107edd0406ffa4e419def8df391048fb9cb.tar.bz2
gentoo-20db7107edd0406ffa4e419def8df391048fb9cb.zip
dev-ros/depth_image_proc: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros/depth_image_proc')
-rw-r--r--dev-ros/depth_image_proc/Manifest1
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.12.19.ebuild30
-rw-r--r--dev-ros/depth_image_proc/files/gcc6.patch35
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-ros/depth_image_proc/Manifest b/dev-ros/depth_image_proc/Manifest
index b50ff7ba4d9b..f6e12d8df502 100644
--- a/dev-ros/depth_image_proc/Manifest
+++ b/dev-ros/depth_image_proc/Manifest
@@ -1,2 +1 @@
-DIST image_pipeline-1.12.19.tar.gz 130635 SHA256 fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97 SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba WHIRLPOOL ecb1cdcc07109d3781bb82e88c0fe7e91754b2dfac0bfc7f5d053e6df9ce78b95b4131a9b65715fbce1b44b0acab6f833bd9c0d4f2fb68718fee4f4bfd586c63
DIST image_pipeline-1.12.20.tar.gz 137888 SHA256 b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53 SHA512 37a45cfcc8bdb8b40477860e29f72671d423d4531156f5901128c32a6c41d27f235cdac216502d614ab7ddab5e66c2f343baaa0fd22cf83cb38e667fbbc111c5 WHIRLPOOL 8dda5d84af0929a983e6a2cb54697ee50d3036399a05bff50ae711fb4e8638e8763de407b65beb14d65b2cd48e3b200c84af95cee7da48609448f102d0bfdadc
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.12.19.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.12.19.ebuild
deleted file mode 100644
index 09386f1f5f05..000000000000
--- a/dev-ros/depth_image_proc/depth_image_proc-1.12.19.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cv_bridge
- media-libs/opencv:=
- dev-ros/eigen_conversions
- dev-ros/image_geometry
- dev-ros/image_transport
- dev-ros/message_filters
- dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/tf2
- dev-ros/tf2_ros
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/depth_image_proc/files/gcc6.patch b/dev-ros/depth_image_proc/files/gcc6.patch
deleted file mode 100644
index 694e2a1b18f3..000000000000
--- a/dev-ros/depth_image_proc/files/gcc6.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-commit 6c2d65452bd5fe62723988a1a570789921900d59
-Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Fri Sep 30 15:39:47 2016 +0200
-
- address gcc6 build error
-
- With gcc6, compiling fails with `stdlib.h: No such file or directory`,
- as including '-isystem /usr/include' breaks with gcc6, cf.,
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
-
- This commit addresses this issue for this package in the same way
- it was addressed in various other ROS packages. A list of related
- commits and pull requests is at:
-
- https://github.com/ros/rosdistro/issues/12783
-
- Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-
-diff --git a/depth_image_proc/CMakeLists.txt b/depth_image_proc/CMakeLists.txt
-index 0a7c7e2..6ceebfe 100644
---- a/depth_image_proc/CMakeLists.txt
-+++ b/depth_image_proc/CMakeLists.txt
-@@ -10,11 +10,7 @@ catkin_package(
- find_package(Boost REQUIRED)
- find_package(Eigen REQUIRED)
- find_package(OpenCV REQUIRED)
--include_directories(include
-- SYSTEM ${BOOST_INCLUDE_DIRS}
-- ${catkin_INCLUDE_DIRS}
-- ${EIGEN_INCLUDE_DIRS}
--)
-+include_directories(include ${BOOST_INCLUDE_DIRS} ${catkin_INCLUDE_DIRS} ${EIGEN_INCLUDE_DIRS})
-
- add_library(${PROJECT_NAME} src/nodelets/convert_metric.cpp
- src/nodelets/crop_foremost.cpp