summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:23:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 19:04:19 +0200
commitafe184021c2b8993431d372c7c03e5bc187b2b1d (patch)
treec71f3bf3cdf95d2b508220ac18e3d9913526ebf1 /dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
parentchromium.eclass: Also fix ERROR variables (diff)
downloadgentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.tar.gz
gentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.tar.bz2
gentoo-afe184021c2b8993431d372c7c03e5bc187b2b1d.zip
dev-ros/diagnostic_aggregator: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
new file mode 100644
index 000000000000..c01522baab44
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"