summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-21 10:49:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-21 11:03:11 +0200
commit4c69edb6e854b1fa55317de3bedeb0fe2755dfe1 (patch)
treef67bae7e7b96cac1b5f08cda134a2a85b2e31eac /dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild
parentdev-ros/diagnostic_aggregator: Bump to 1.9.2. (diff)
downloadgentoo-4c69edb6e854b1fa55317de3bedeb0fe2755dfe1.tar.gz
gentoo-4c69edb6e854b1fa55317de3bedeb0fe2755dfe1.tar.bz2
gentoo-4c69edb6e854b1fa55317de3bedeb0fe2755dfe1.zip
dev-ros/diagnostic_analysis: Bump to 1.9.2.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild
new file mode 100644
index 000000000000..b2b767204efd
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"