summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 19:11:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:23:50 +0200
commit24fc8105e752cde59df622253c7fa5ec58e6a69d (patch)
tree9f2a5331f18ebc5ebaf24f5f809eb2f0336cb7bf /dev-ros/fake_localization
parentdev-ros/fake_localization: Remove old (diff)
downloadgentoo-24fc8105e752cde59df622253c7fa5ec58e6a69d.tar.gz
gentoo-24fc8105e752cde59df622253c7fa5ec58e6a69d.tar.bz2
gentoo-24fc8105e752cde59df622253c7fa5ec58e6a69d.zip
dev-ros/fake_localization: fix build with boost 1.70
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/fake_localization')
-rw-r--r--dev-ros/fake_localization/fake_localization-1.16.2.ebuild3
-rw-r--r--dev-ros/fake_localization/files/boost170.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-ros/fake_localization/fake_localization-1.16.2.ebuild b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
index 0c7895911491..946772aaddd8 100644
--- a/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
+++ b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -27,3 +27,4 @@ RDEPEND="
dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/boost170.patch" )
diff --git a/dev-ros/fake_localization/files/boost170.patch b/dev-ros/fake_localization/files/boost170.patch
new file mode 100644
index 000000000000..b7f877a82b4f
--- /dev/null
+++ b/dev-ros/fake_localization/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: fake_localization/CMakeLists.txt
+===================================================================
+--- fake_localization.orig/CMakeLists.txt
++++ fake_localization/CMakeLists.txt
+@@ -14,7 +14,7 @@ find_package(catkin REQUIRED
+ )
+
+
+-find_package(Boost REQUIRED COMPONENTS signals)
++find_package(Boost REQUIRED COMPONENTS)
+
+ catkin_package(
+ CATKIN_DEPENDS