summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 21:18:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 21:22:08 +0200
commitafa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730 (patch)
treea425bd85cd2801bb606fd66d6c0f216b9a7fd0af /dev-ros/filters/filters-9999.ebuild
parentdev-ros/control_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.tar.gz
gentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.tar.bz2
gentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.zip
dev-ros/filters: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/filters/filters-9999.ebuild')
-rw-r--r--dev-ros/filters/filters-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/filters/filters-9999.ebuild b/dev-ros/filters/filters-9999.ebuild
new file mode 100644
index 000000000000..4b50ee0a0497
--- /dev/null
+++ b/dev-ros/filters/filters-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/filters"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for processing data as a sequence of filters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp
+ dev-ros/pluginlib"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )