summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-21 10:04:40 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-21 10:21:13 +0100
commit9fb197462f8fd965267e8fa0c4a1bd36114cc3eb (patch)
tree984b1877c24cfafd88314fc05f42d7be169d1660 /dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild
parentdev-ros/driver_base: Add python 3.5 support (diff)
downloadgentoo-9fb197462f8fd965267e8fa0c4a1bd36114cc3eb.tar.gz
gentoo-9fb197462f8fd965267e8fa0c4a1bd36114cc3eb.tar.bz2
gentoo-9fb197462f8fd965267e8fa0c4a1bd36114cc3eb.zip
dev-ros/gazebo_plugins: Add python 3.4/3.5 support and missing PYTHON_USEDEP on some packages
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild')
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild
index 2c0abf6a639e..c2245b9b1082 100644
--- a/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
KEYWORDS="~amd64"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
@@ -29,8 +29,8 @@ RDEPEND="
dev-ros/urdf
dev-ros/tf
dev-ros/tf2_ros
- dev-ros/dynamic_reconfigure
- dev-ros/driver_base
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/driver_base[${PYTHON_USEDEP}]
dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/pcl_conversions