summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-10 07:47:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-10 07:47:55 +0100
commitc440724b106e10c7c326802896a7bd276c454687 (patch)
treea166d939c4b8d74b4d2c23252827683bed6d5176 /dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild
parentdev-ruby/dbf: add 3.0.0 (diff)
downloadgentoo-c440724b106e10c7c326802896a7bd276c454687.tar.gz
gentoo-c440724b106e10c7c326802896a7bd276c454687.tar.bz2
gentoo-c440724b106e10c7c326802896a7bd276c454687.zip
dev-ros/hector_compressed_map_transport: Bump to 0.3.4.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild')
-rw-r--r--dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild
new file mode 100644
index 000000000000..8c5f1556370f
--- /dev/null
+++ b/dev-ros/hector_compressed_map_transport/hector_compressed_map_transport-0.3.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Means for transporting compressed map data through the use of image_transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/hector_map_tools
+ dev-ros/image_transport
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"