summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 21:11:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 21:35:25 +0100
commita95e8dec516b6817352f3d40a95f5506c5e13a22 (patch)
tree9aa52704901997ae24b3d9e40a9134e2401fc9e1 /dev-ros/hector_geotiff
parentdev-ros/hector_compressed_map_transport: Remove old (diff)
downloadgentoo-a95e8dec516b6817352f3d40a95f5506c5e13a22.tar.gz
gentoo-a95e8dec516b6817352f3d40a95f5506c5e13a22.tar.bz2
gentoo-a95e8dec516b6817352f3d40a95f5506c5e13a22.zip
dev-ros/hector_geotiff: Remove old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_geotiff')
-rw-r--r--dev-ros/hector_geotiff/Manifest2
-rw-r--r--dev-ros/hector_geotiff/files/qt5.patch91
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild33
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild31
4 files changed, 0 insertions, 157 deletions
diff --git a/dev-ros/hector_geotiff/Manifest b/dev-ros/hector_geotiff/Manifest
index 5621bc8ca341..82bb9ffe5c37 100644
--- a/dev-ros/hector_geotiff/Manifest
+++ b/dev-ros/hector_geotiff/Manifest
@@ -1,3 +1 @@
-DIST hector_slam-0.4.1.tar.gz 66772 BLAKE2B ad6f5596ea1fca2ed68017534280a4d622179de8df4c039e95f3e87a0e591212944d65e4d507194eb33584f7f55cba4fe398b19f5a22bfb3afce1b2406d1635d SHA512 bd0932971114f13c41c6e346756f2c95cc0a9a011d11202792a6f837757a144355e05c3e7ed1afa574b743166a78f1a7855c5693b0c57378611e50c386c2483e
-DIST hector_slam-0.5.0.tar.gz 160320 BLAKE2B 9109b81740296aada8b0987d153774ac547cf063546973e8034849a5c81117c10047c12ca65f15feae5355c35a6e746cbf0ab8fa2089d282beb1f7aa06528254 SHA512 d9d7e0e7de96330358bcd98de2083ee67e0d232d6758599291607951696aef5dd93b335252448ddec59202627f69fd5a9122c0f3a2829744b4b6417906aab3ed
DIST hector_slam-0.5.1.tar.gz 160548 BLAKE2B 7a4cf8f0c1a387c4de08620478c8954df27a3ae6d23b1f11bf8574a1f62f8e742934cfb08d278e881dfb73941be89de43fe97813c992f9aa53a97487b0ae2efb SHA512 b46131a4ba3bc1eaef27091040a29f4b0f7d1a80f54e2f2756f13e08ef4d4b37ad4fef2802737bb31afe7cbbbf0e49573b87d7df991e7a19e80219a4158e3064
diff --git a/dev-ros/hector_geotiff/files/qt5.patch b/dev-ros/hector_geotiff/files/qt5.patch
deleted file mode 100644
index 07b44ef23a13..000000000000
--- a/dev-ros/hector_geotiff/files/qt5.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Index: hector_geotiff/CMakeLists.txt
-===================================================================
---- hector_geotiff.orig/CMakeLists.txt
-+++ hector_geotiff/CMakeLists.txt
-@@ -9,7 +9,7 @@ find_package(catkin REQUIRED COMPONENTS
- ## System dependencies are found with CMake's conventions
- # find_package(Boost REQUIRED COMPONENTS system)
-
--find_package(Qt4 4.6 COMPONENTS QtCore QtGui REQUIRED)
-+find_package(Qt5 5.7 COMPONENTS Core Gui Widgets REQUIRED)
-
- # Find Eigen3 (from http://wiki.ros.org/jade/Migration)
- find_package(Eigen3)
-@@ -24,8 +24,7 @@ else()
- set(EIGEN3_INCLUDE_DIRS ${EIGEN3_INCLUDE_DIR})
- endif()
-
--include(${QT_USE_FILE})
--
-+add_compile_options(-fPIC)
-
- ## Uncomment this if the package has a setup.py. This macro ensures
- ## modules and global scripts declared therein get installed
-@@ -82,10 +81,14 @@ include_directories(include include/hect
- include_directories(
- ${catkin_INCLUDE_DIRS}
- ${EIGEN3_INCLUDE_DIRS}
-+ ${Qt5Core_INCLUDE_DIRS}
-+ ${Qt5Widgets_INCLUDE_DIRS}
-+ ${Qt5Gui_INCLUDE_DIRS}
- )
-
- add_library(geotiff_writer src/geotiff_writer/geotiff_writer.cpp)
--target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${QT_LIBRARIES})
-+target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${Qt5Core_LIBRARIES}
-+ ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES})
- add_dependencies(geotiff_writer ${catkin_EXPORTED_TARGETS})
-
- add_executable(geotiff_saver src/geotiff_saver.cpp)
-Index: hector_geotiff/include/hector_geotiff/geotiff_writer.h
-===================================================================
---- hector_geotiff.orig/include/hector_geotiff/geotiff_writer.h
-+++ hector_geotiff/include/hector_geotiff/geotiff_writer.h
-@@ -37,7 +37,7 @@
- #include <nav_msgs/MapMetaData.h>
-
- #include <QtGui/QImage>
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
- #include <QtGui/QFont>
- #include <QtGui/QPen>
-
-Index: hector_geotiff/src/geotiff_node.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_node.cpp
-+++ hector_geotiff/src/geotiff_node.cpp
-@@ -40,7 +40,7 @@
-
- #include <Eigen/Geometry>
-
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
-
- #include <hector_map_tools/HectorMapTools.h>
-
-Index: hector_geotiff/src/geotiff_saver.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_saver.cpp
-+++ hector_geotiff/src/geotiff_saver.cpp
-@@ -34,7 +34,7 @@
-
- #include <Eigen/Geometry>
-
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
-
- #include <hector_map_tools/HectorMapTools.h>
-
-Index: hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
-===================================================================
---- hector_geotiff.orig/src/geotiff_writer/geotiff_writer.cpp
-+++ hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
-@@ -31,7 +31,7 @@
-
- #include <QtGui/QPainter>
- #include <QtGui/QImageWriter>
--#include <QtGui/QApplication>
-+#include <QtWidgets/QApplication>
- #include <QtCore/QFile>
- //#include <QtCore/QDateTime>
- #include <QtCore/QTime>
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild
deleted file mode 100644
index 0fd828ef8d7d..000000000000
--- a/dev-ros/hector_geotiff/hector_geotiff-0.4.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_map_tools
- dev-ros/pluginlib
- dev-libs/tinyxml2:=
- dev-libs/console_bridge:=
- dev-ros/roscpp
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3"
-
-PATCHES=( "${FILESDIR}/qt5.patch" )
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild
deleted file mode 100644
index 5dedc3aec918..000000000000
--- a/dev-ros/hector_geotiff/hector_geotiff-0.5.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Saves occupancy grid map, robot trajectory and object data to GeoTiff images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/hector_map_tools
- dev-ros/pluginlib
- dev-libs/tinyxml2:=
- dev-libs/console_bridge:=
- dev-ros/roscpp
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-libs/boost:=
-"
-DEPEND="${RDEPEND}
- dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3"