summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 14:16:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 14:33:33 +0200
commit08d802ed52496db8d1b39ae8d4d419dcd9d2f9e9 (patch)
treef05567c5721ce578f916e6eb2a4a17718d1940e0 /dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
parentdev-ros/interval_intersection: bump eapi (diff)
downloadgentoo-08d802ed52496db8d1b39ae8d4d419dcd9d2f9e9.tar.gz
gentoo-08d802ed52496db8d1b39ae8d4d419dcd9d2f9e9.tar.bz2
gentoo-08d802ed52496db8d1b39ae8d4d419dcd9d2f9e9.zip
dev-ros/image_cb_detector: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild')
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 2502c78f860a..4667fcb87175 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/calibration"
CATKIN_HAS_MESSAGES=yes
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/actionlib_msgs dev-ros/std_msgs"
@@ -23,10 +22,12 @@ RDEPEND="
dev-ros/image_transport
dev-ros/message_filters
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/rospy[${PYTHON_USEDEP}]
dev-libs/boost:=[threads]
"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/boost170.patch" )
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )