summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 19:23:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:23:56 +0200
commitc32cfbec3d05b6fbcfb1f557f1897a2af3f6a09e (patch)
treecfe9eb69bcef37b06dc18091e6c9c0985e7ee967 /dev-ros/image_cb_detector
parentdev-ros/hector_mapping: fix build with boost 1.70 (diff)
downloadgentoo-c32cfbec3d05b6fbcfb1f557f1897a2af3f6a09e.tar.gz
gentoo-c32cfbec3d05b6fbcfb1f557f1897a2af3f6a09e.tar.bz2
gentoo-c32cfbec3d05b6fbcfb1f557f1897a2af3f6a09e.zip
dev-ros/image_cb_detector: fix build with boost 1.70
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/files/boost170.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild4
2 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/image_cb_detector/files/boost170.patch b/dev-ros/image_cb_detector/files/boost170.patch
new file mode 100644
index 000000000000..f8ae562dadc5
--- /dev/null
+++ b/dev-ros/image_cb_detector/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: image_cb_detector/CMakeLists.txt
+===================================================================
+--- image_cb_detector.orig/CMakeLists.txt
++++ image_cb_detector/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 2.8.3)
+ project(image_cb_detector)
+
+-find_package(Boost REQUIRED thread signals)
++find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED actionlib actionlib_msgs calibration_msgs cv_bridge genmsg geometry_msgs image_transport message_filters roscpp sensor_msgs std_msgs)
+ find_package(OpenCV REQUIRED)
+
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
index 8b96da0e6b06..2502c78f860a 100644
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -29,4 +29,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/boost170.patch" )