summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-10 16:51:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-10 18:34:45 +0100
commit8d6889c4b67a1c319c5aada108fa771a7f1e3a10 (patch)
tree59889fa0e1a46e2927d127c10d36f050d8fe56a0 /dev-ros/image_proc
parentdev-ros/depth_image_proc: Bump to 1.13.0. (diff)
downloadgentoo-8d6889c4b67a1c319c5aada108fa771a7f1e3a10.tar.gz
gentoo-8d6889c4b67a1c319c5aada108fa771a7f1e3a10.tar.bz2
gentoo-8d6889c4b67a1c319c5aada108fa771a7f1e3a10.zip
dev-ros/image_proc: Bump to 1.13.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_proc')
-rw-r--r--dev-ros/image_proc/Manifest1
-rw-r--r--dev-ros/image_proc/image_proc-1.13.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/image_proc/Manifest b/dev-ros/image_proc/Manifest
index 3bce8c29f7e1..ac6a860a5299 100644
--- a/dev-ros/image_proc/Manifest
+++ b/dev-ros/image_proc/Manifest
@@ -1,2 +1,3 @@
DIST image_pipeline-1.12.22.tar.gz 139237 BLAKE2B 9c4ad324494f7e9db935cceed562840bb7ed7af730655398c9ac410722faf7d6747010ef0bbee55f14b555b6b2a6756de3edde31d84c3ae3fad123cea4a85bfe SHA512 34c17bd13625dc0a3c94639ce5ea17cc7674b0035b425c10020178d08037fb4fd081a84d7e83c75822f58c0ba2faead351702dbbc75c821d2f8c17bda351c560
DIST image_pipeline-1.12.23.tar.gz 139986 BLAKE2B 22349762d6119a2246cb812cce310ebe98b046881ea1192425c4a0ebd7717b8e2768cd4f357ebf905f81e2be9816b7b864ee1040e570d156f9377f51386274a1 SHA512 cb9df1845ae3e7a08788e8f401b8e1b5354cc06f9a4b1aa62d2729c5d84033adbc0049a837236644a0b89951a172b230d4c074bc403bb265ba6cf0ad8016dbdd
+DIST image_pipeline-1.13.0.tar.gz 143194 BLAKE2B 618f95271196e37126f158e3454ffb81b1543af1fd87db281f6b8ec00bcf37a812139063318b576c7d39cde7828fc45e3caec24fcbb3e6b4a047d16907427ad2 SHA512 91aeb8e7a14090679e639a65de434c51e8d67f9a9c53bde69f9a5b4f3ae64e5fb1470baf5d2ba33debd2f46cd1699cf69bec53ef2160ea405c46c0e19bb3c3af
diff --git a/dev-ros/image_proc/image_proc-1.13.0.ebuild b/dev-ros/image_proc/image_proc-1.13.0.ebuild
new file mode 100644
index 000000000000..9a57f7096740
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv:=
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"