summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:13:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:29 +0200
commit43c13fcbd389bebcebb98fa9063fae562ccd2ba5 (patch)
treeecdb1c34d06a9b8283227eb23f9b2ea2f6d0243d /dev-ros/image_view
parentdev-ros/image_rotate: Bump to 1.15.2. (diff)
downloadgentoo-43c13fcbd389bebcebb98fa9063fae562ccd2ba5.tar.gz
gentoo-43c13fcbd389bebcebb98fa9063fae562ccd2ba5.tar.bz2
gentoo-43c13fcbd389bebcebb98fa9063fae562ccd2ba5.zip
dev-ros/image_view: Bump to 1.15.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_view')
-rw-r--r--dev-ros/image_view/Manifest1
-rw-r--r--dev-ros/image_view/image_view-1.15.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/image_view/Manifest b/dev-ros/image_view/Manifest
index fe3876d80ca3..1b784a13a082 100644
--- a/dev-ros/image_view/Manifest
+++ b/dev-ros/image_view/Manifest
@@ -1,2 +1,3 @@
DIST image_pipeline-1.12.23.tar.gz 139986 BLAKE2B 22349762d6119a2246cb812cce310ebe98b046881ea1192425c4a0ebd7717b8e2768cd4f357ebf905f81e2be9816b7b864ee1040e570d156f9377f51386274a1 SHA512 cb9df1845ae3e7a08788e8f401b8e1b5354cc06f9a4b1aa62d2729c5d84033adbc0049a837236644a0b89951a172b230d4c074bc403bb265ba6cf0ad8016dbdd
DIST image_pipeline-1.13.0.tar.gz 143194 BLAKE2B 618f95271196e37126f158e3454ffb81b1543af1fd87db281f6b8ec00bcf37a812139063318b576c7d39cde7828fc45e3caec24fcbb3e6b4a047d16907427ad2 SHA512 91aeb8e7a14090679e639a65de434c51e8d67f9a9c53bde69f9a5b4f3ae64e5fb1470baf5d2ba33debd2f46cd1699cf69bec53ef2160ea405c46c0e19bb3c3af
+DIST image_pipeline-1.15.2.tar.gz 147570 BLAKE2B 7e6ecad344e38426148017c4bdd109cdb505201256b811d7479b2fa5f2b6a94f94708ffd0e2a3c273f09fb8db0afdedb6955320bc142e4b48fbf94eeef45b453 SHA512 8fe9fa7759d83b2585589c6667c82b154c6ab748aa1644e8a58c75550e4c581fdea1b42f91a8c64df4eb7a06b33a76e55325268f314f3ec1f06ee38ee7b06bfc
diff --git a/dev-ros/image_view/image_view-1.15.2.ebuild b/dev-ros/image_view/image_view-1.15.2.ebuild
new file mode 100644
index 000000000000..e471e1508b6c
--- /dev/null
+++ b/dev-ros/image_view/image_view-1.15.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple viewer for ROS image topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ media-libs/opencv:=
+ x11-libs/gtk+:2
+ dev-ros/camera_calibration_parsers
+ >=dev-ros/cv_bridge-1.11.10
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"